Microsoft System Center Operations Manager 2007 的 Microsoft System Center Configuration Manager 2007 管理組件使用者手冊
請參閱
System Center Configuration Manager 2007 標誌

歡迎使用 System Center Operations Manager 2007 的 Microsoft System Center Configuration Manager 2007 (ConfigMgr) 管理組件。此管理組件可協助系統管理員管理 Configuration Manager 2007 伺服器。

取得最新的管理組件與管理組件文件

您可以在 http://go.microsoft.com/fwlink/?LinkId=103233 找到 Configuration Manager 2007 管理組件。

新功能

如需管理組件的變更清單，請參閱 Configuration Manager 2007 管理組件的新功能。

請參閱

概念

Configuration Manager 2007 的管理組件監視案例

其它資源

Configuration Manager 2007 管理組件概觀
部署 Configuration Manager 2007 管理組件
執行 Configuration Manager 2007 管理組件的操作工作
疑難排解 Configuration Manager 2007 管理組件問題
Configuration Manager 2007 管理組件的參考資料


Configuration Manager 2007 管理組件概觀

本指南將讓您熟悉 Configuration Manager 2007 管理組件的相關部署和技術資訊。您可以利用這份資訊規劃管理組件的部署、了解管理組件提供的功能，並了解如何利用這些功能讓您的 IT 組織受益。

「Operations Manager 2007 的 System Center Configuration Manager 2007 管理組件」為 Configuration Manager 2007 監視提供了加強的功能，包括下列項目：

  • 監視所有 Configuration Manager 2007 服務的啟動和停止，包括關鍵的依存服務，例如 Windows Management Instrumentation (WMI)、IIS Admin Service、World Wide Web Publishing Service、Windows Deployment Services Server、Trivial FTP Daemon、Background Intelligent Transfer Service (BITS) 與 Microsoft SQL Server™。
  • 產生嚴重的 Configuration Manager 2007 狀態訊息時向 Configuration Manager 2007 系統管理員發出警示。
  • 監視探索資料記錄 (DDR) 的待處理項目、軟體清查、硬體清查、狀態訊息、狀況訊息，以及在主要站台伺服器和管理點上的軟體計量。
  • 監視站台系統上的寄件匣待處理項目。
  • 監視元件與站台系統角色健康狀態。
  • 監視集合評估、狀況訊息摘要，以及站台維護工作 (包括站台備份)。
  • 監視 SMS Executive 損毀傾印。
  • 監視一般 CPU、記憶體與磁碟系統資源使用狀況。
  • 監視處理速度。
  • 利用檢視和報告，監視多個 Configuration Manager 效能計數器的效能趨勢。
  • 所有警示和處理規則的產品知識內容。
  • 偵測所有 Configuration Manager 2007 電腦、類別與電腦群組。
  • Configuration Manager 2007 檢視。
  • 報告會顯示 Configuration Manager 2007 伺服器群組的效能、可用性及設定。這些連結的報告提供 Systems Center Operations Manager 2007 在效能、設定和可用性趨勢等方面的增強報告功能。
  • 執行 Configuration Manager 2007 系統管理員主控台應用程式的工作。
  • 電腦狀況檢視包含所有 Configuration Manager 2007 伺服器角色與 Configuration Manager 2007 Client 的健康狀態。
  • 站台階層與站台狀況檢視可用於顯示階層中與階層本身的站台健康狀態。
  • 重要 Configuration Manager 2007 伺服器與 Configuration Manager 2007 用戶端資訊的服務探索。
  • Configuration Manager 2007 站台階層的拓撲圖表。
  • Configuration Manager 2007 可透過 Configuration Manager 2007 程式內容設定發佈軟體失敗的警示。

如需監視案例與功能的詳細資訊，請參閱 Configuration Manager 2007 的管理組件監視案例。

Configuration Manager 2007 管理組件並非為下列目的而設計：

  • 提供監視 System Management Server (SMS) 1.2、SMS 2.0 或 SMS 2003 或任何 R2 或 Service Pack 發行的功能。
  • 監視混合的 SMS 與 Configuration Manager 環境。安裝並一起執行 SMS 1.2、SMS 2.0、SMS 2003 與 Configuration Manager 安裝的混合環境。SMS 2003 子站台可以往上向 Configuration Manager 2007 父站台報告。
  • 提供可用於監視 Configuration Manager 2007 僅用戶端電腦 (執行 Configuration Manager 2007 用戶端) 的豐富功能。
  • 提供立即可用的監視解決方案，無須任何修改即可管理任何 Configuration Manager 2007 安裝。每個 Configuration Manager 2007 安裝的規則閾值都不同，客戶必須自訂規則。

在此章節中

Configuration Manager 2007 管理組件的新功能

Configuration Manager 2007 管理組件的建議知識

支援的 Configuration Manager 2007 管理組件設定

請參閱

概念

開始使用 Configuration Manager 2007 管理組件
Configuration Manager 2007 的管理組件監視案例

其它資源

部署 Configuration Manager 2007 管理組件
執行 Configuration Manager 2007 管理組件的操作工作
Configuration Manager 2007 管理組件的參考資料
疑難排解 Configuration Manager 2007 管理組件問題


Configuration Manager 2007 管理組件的新功能

Operations Manager 2007 的 System Center Configuration Manager 2007 管理組件包含新的監視功能與新的監視機制。監視過時角色與資料來源的功能已移除。

加入 Configuration Manager 2007 功能的支援

Configuration Management 2007 管理組件加入了監視下列 Configuration Manager 2007 功能的功能：

  • 想要的設定管理
  • 作業系統部署
  • 網路存取保護 (NAP)。Configuration Management 2007 Service Pack 1 以前的版本不支援 NAP 監視。
  • 裝置管理
  • 線上醒機
  • 以 VSS 為基礎的備份
  • 行動用戶端；著重於分公司與網際網路的基礎結構

加入 SQL Server 可用性監視

Configuration Manager 資料庫現在可從站台伺服器監視，而不是從 SQL Server 本機監視。此監視是由 SMS_DATABASE_NOTIFICATION_MONITOR 所執行，它是 SMS Executive 服務的執行緒。您可以使用可用性報告來監視 SQL 伺服器可用性。

加入裝置管理點可用性監視

裝置管理點監視是由 MP Control Manager 透過發出綜合交易至裝置管理點 (指示它執行自我測試) 而執行的。接著該測試的結果會反映為角色的可用性，此可用性可透過警示與報告來監視。

加入發佈點可用性監視

發佈點可用性監視目前只能由分支發佈點使用。角色的可用性是由 Configuration Manager Client 上執行的 BDP 代理程式報告。

加入軟體更新點可用性監視

軟體更新點可用性會反映角色的健康狀態與其可用性，以從 WSUS Server 同步更新。

加入狀態移轉點可用性監視

狀態移轉點監視是由 SMP Control Manager 透過發出綜合交易至狀態移轉點 (指示它執行自我測試) 而執行的。接著該測試的結果會反映為角色的可用性，此可用性可透過警示與報告來監視。

加入 PXE 服務點可用性監視

PXE 服務點監視是由 PSP Control Manager 透過發出綜合交易至 PXE 服務點 (指示它存取站台資料庫) 而執行的。接著該測試的結果會反映為角色的可用性，此可用性可透過警示與報告來監視。

加入系統健康狀態驗證可用性監視

系統健康狀態驗證可用性與健康狀態是由系統健康狀態驗證本身動態報告，並反映其目前的內部運作狀態，這可透過警示與報告監視。

加入網路負載平衡管理點可用性監視

為了針對 NLB 管理點提供實體與虛擬管理點監視 (以進行網路負載平衡處理)，已更新管理點控制管理員。監視 NLB 可用性的執行方式非常類似於在 Configuration Manager 2007 中監視實體管理點。此外，也會監視 NLB 中每個節點的狀態。

加入元件可用性監視

許多元件的設計都會產生活動訊號，其中包含其可性用狀態。元件可用性問題是透過警示報告。

加入 Configuration Manager 工作監視

工作會定期執行以進行集合評估、狀態訊息摘要，以及站台維護 (包括備份)。站台資料庫中的資料表已擴充且元件已更新，以報告工作期間與狀態。現在會報告執行時間超出預期或失敗的工作。

更新收件匣檔案計數閾值規則

收件匣現在可由管理組件效能計數器監視。過去這些計數器是由指令碼監視。

加入寄件匣監視

寄件夾監視會計算寄件匣中的檔案數目，而且此監視會由效能計數器報告。

更新從 Operations Manager 主控台啟動 Configuration Manager 2007 工作的方式

在 SMS 2003 中，當您安裝 SMS 系統管理員主控台時所建立的 SMS_ADMIN_UI_PATH 環境變數是使用者環境變數，因此只有主控台的安裝人員可以從操作主控台啟動 SMS 工作。在 Configuration Manager 2007 中，此環境變數現在是系統環境變數，因此不再有上述限制。下列工作會受到影響：

  • 資源總管
  • Configuration Manager 主控台
  • 服務管理員
  • 狀態訊息
  • 當 ConfigMgr Server 類別的執行個體存在時，即可從工作窗格使用這些工作。

更新 Configuration Manager 2007 的維護模式

Operations Manager 維護模式現在是由下列 Configuration Manager 2007 功能完成：

  • 備份與復原
  • 軟體更新管理
  • 軟體發佈

備份與復原仍會執行服務的關閉作業，但它在執行此動作之前會將 Operations Manager 代理程式切換至維護模式，您再也不需要在管理組件中利用自訂服務監視功能來完成此動作。

更新 Configuration Manager 站台階層圖表

在 Operations Manager (MOM) 2007 中，SMS 2003 的站台階層圖表已更新為向上鑽研 (roll up) 狀態。Configuration Manager 2007 管理組件的圖表

更新 Configuration Manager 的報告

Configuration Manager 包含新的報告，這些報告著重在站台系統角色的效能計數器，以及物件處理計數器的效能計數器，例如 DDR 相關計數器。如需有關新報告的詳細資訊，請參閱 Configuration Manager 2007 管理組件的報告。

移除 Configuration Manager 傳送者角色

Configuration Manager 2007 中已不再支援遠端傳送者。管理組件已移除對於傳送者角色的管理組件支援。

移除用戶端存取點角色

Configuration Manager 2007 已移除這些角色。健全狀況總管也已移除對這些角色的監視。

移除用戶端設定要求寄件匣的監視

因為 CCR 已不再通過此寄件匣，管理組件已不支援監視 Configuration Manager 2007 用戶端設定要求寄件匣 (outbox ccr.box)。


Configuration Manager 2007 管理組件的建議知識

如果要部署並操作 Configuration Manager 2007 管理組件，建議您具備下列知識與技能：

  • Operations Manager 2007 監視功能的作業知識。如需 Operations Manager 2007 的相關資訊，請參閱 Operations Manager 2007 網頁 (http://go.microsoft.com/fwlink/?LinkID=83259) (英文)。
  • 了解 Operations Manager 2007 的設計架構，以及部署於組織中的設計架構。
  • 熟悉《System Center Operations Manager 2007 部署手冊》中，部署管理組件的建議程序。
  • Configuration Manager 概念與術語的作業知識。如需 Configuration Manager 2007 的相關資訊，請參閱 Configuration Manager 文件庫網頁 (http://go.microsoft.com/fwlink/?LinkId=98803) (英文)。
  • 瞭解 Configuration Manager 2007 管理能力與其檢測意義。如需維護 Configuration Manager 2007 的相關資訊，請參閱「維護 Configuration Manager 2007」(http://go.microsoft.com/fwlink/?LinkId=102324) (英文) 與「管理能力 TechCenter」(http://go.microsoft.com/fwlink/?LinkId=102326) (英文)。

請參閱

概念

Configuration Manager 2007 的管理組件監視案例

其它資源

部署 Configuration Manager 2007 管理組件
執行 Configuration Manager 2007 管理組件的操作工作


支援的 Configuration Manager 2007 管理組件設定

System Center Configuration Manager 2007 和 Systems Center Operations Manager 2007 的需求相關文件可在其各自的部署手冊中找到。Configuration Manager 2007 管理組件只能監視 Configuration Manager 2007。

  • 安裝 Configuration Manager 2007 管理組件之前必須先安裝「Operations Manager 2007 MOM 2005 回溯相容性管理組件更新」。如需「OpsMgr 2007 MOM 2005 回溯相容性管理組件更新」的詳細資訊，請參閱下載網頁 (http://go.microsoft.com/fwlink/?LinkId=101878)。
  • 此 Configuration Manager 2007 管理組件不會監視 System Management Server (SMS) 1.2、SMS 2.0 或 SMS 2003。
  • 若要監視 SMS 2003，請使用「Microsoft System Center Operations Manager 2007 的 Microsoft SMS 2003 管理組件」(http://go.microsoft.com/fwlink/?LinkId=102297) 或「MOM 2005 的 Systems Management Server (SMS) 2003 管理組件」(http://go.microsoft.com/fwlink/?LinkId=102297)。

請參閱

其它資源

Configuration Manager 2007 管理組件概觀
Configuration Manager 2007 管理組件的參考資料
疑難排解 Configuration Manager 2007 管理組件問題


部署 Configuration Manager 2007 管理組件

本節包含部署、測試與自訂 Configuration Manager 2007 管理組件的步驟。

在此章節中

開始使用 Configuration Manager 2007 管理組件

部署 Operations Manager 2007 代理程式

測試與試驗 Configuration Manager 2007 管理組件

自訂 Configuration Manager 2007 管理組件

請參閱

概念

Configuration Manager 2007 管理組件的已知問題
Configuration Manager 2007 的管理組件監視案例

其它資源

Configuration Manager 2007 管理組件概觀


開始使用 Configuration Manager 2007 管理組件

在匯入管理組件之前

在部署 Microsoft® Configuration Manager 2007 管理組件之前，請檢閱 Operations Manager 2007 網頁 (http://go.microsoft.com/fwlink/?LinkID=83259) (英文) 上的《Microsoft Operations Manager 2007 部署手冊》(英文)。本節提供部署 Operations Manager 管理組件的其他指示。

若要部署 Configuration Manager 2007 管理組件，您必須完成下列步驟：

  • 根據營運與組織需求，來設計監視環境。考量效能與規模因素。建議您監視所有主要站台伺服器與預設管理點。
  • 針對所要監視的所有 Configuration Manager 2007 伺服器元件電腦，部署 Operations Manager 2007 代理程式。最好採用累加式方法。
  • 確認所有代理程式均狀況良好。
  • 對 Configuration Manager 2007 提供者與 Configuration Manager 2007 主要站台伺服器設定 Operations Manager 2007 代理程式，如此它們便可以 Proxy 處理其他電腦。
  • 將 Configuration Manager 2007 管理組件匯入 Operations Manager 2007 設定群組。
  • 完成建議的測試和試驗測試工作。
  • 完成建議的調整工作。

如何匯入 Configuration Manager 2007 管理組件

您必須先將管理組件匯入 Operations Manager 2007，才能使用管理組件來監視 Configuration Manager 2007 安裝。如需完成此動作的指示，請參閱 Operations Manager 網頁上的＜如何將管理組件匯入 Operations Manager 2007＞(http://go.microsoft.com/fwlink/?LinkID=98348) (英文)。

建立新的管理組件以供自訂設定

大多數管理組件屬於密封的組件，因此您無法變更管理組件檔案中的任何原始設定。不過，您可以建立自訂項目 (例如覆寫或新的監視物件)，然後將所做的自訂儲存到不同的管理組件。根據預設，Operations Manager 會將所做自訂全部儲存到預設管理組件。最佳作法是您改為對想要自訂的每個密封管理組件建立不同的管理組件。

建立新的管理組件以供儲存覆寫，有下列幾項優點：

  • 這可以將您在測試與生產前環境下所建立的自訂設定匯出到生產環境的程序簡化。例如，改為只匯出包含單一管理組件之自訂設定的管理組件，而不匯出預設管理組件，因為其中包含來自多個管理組件的自訂設定。
  • 這可讓您刪除原來的管理組件，而不需要刪除預設管理組件。內含自訂設定的管理組件依存於原始的管理組件。此依存性會要求您必須先刪除原始的管理組件，才能刪除具有自訂設定的管理組件。如果您將所有自訂設定都儲存在預設管理組件，那麼您必須在刪除預設管理組件之後，才能刪除原始的管理組件。
  • 追蹤和更新個別管理組件的自訂設定比較簡單。

如需密封與非密封管理組件的相關資訊，請參閱＜管理組件格式＞。如需管理組件自訂設定與預設管理組件的相關資訊，請參閱＜關於管理組件＞。

建立新的管理組件以供自訂設定

  1. 開啟操作主控台，然後按一下 [系統管理] 按鈕。

  2. 在 [管理組件] 上按一下滑鼠右鍵，然後按一下 [建立新的管理組件]。

  3. 輸入名稱 (例如「ConfigMgr 2007 MP 自訂」)，然後按 [下一步]。

  4. 按一下 [建立]。

請參閱

概念

部署 Operations Manager 2007 代理程式
測試與試驗 Configuration Manager 2007 管理組件
自訂 Configuration Manager 2007 管理組件


部署 Operations Manager 2007 代理程式

Operations Manager 代理程式會在 Operations Manager 監視的每一部電腦上執行。若要檢視 Configuration Manager 2007 管理組件監視的電腦群組，請參閱本手冊中的 Configuration Manager 2007 管理組件的電腦群組一節。Operations Manager 2007 代理程式會收集受管理電腦上的監視資料、將規則套用到收集的資料，然後將產生的資料傳送到 Data Consolidator Agent Manager (DCAM)。代理程式電腦上的監視功能是由 Operations Manager 2007 Service (HealthService.exe)、Operations Manager 2007 Host (MonitoringHost.exe) 和代理程式動作帳戶提供。

您可以使用 Operations Manager 2007 安裝精靈或 Configuration Manager 軟體發佈來部署 Operations Manager 2007 代理程式。如需部署 Operations Manager 2007 代理程式和使用 Operations Manager 2007 安裝精靈的詳細資訊，請參閱《Microsoft Operations Manager 2007 部署手冊》中的＜探索電腦和部署 Operations Manager 代理程式＞(英文)。如需更多資訊，請參閱 Operations Manager 2007 網頁 (http://go.microsoft.com/fwlink/?LinkID=83259) (英文)。

附註
建議您使用 LocalSystem 帳戶或具有足夠權限的帳戶存取 Configuration Manager WMI 命名空間 root、root\cimv2、 root\sms 和 SMS 登錄機碼與子機碼，在 Configuration Manager 提供者電腦上執行 Operations Manager 2007 代理程式。

若要判斷無代理程式監視是否能用於您的環境中，請參閱 Configuration Manager 2007 的管理組件監視案例中的＜無代理程式監視支援＞。

定義 SMS 環境變數以支援以記錄檔為基礎的規則

Configuration Manager 管理組件中的許多規則都會讀取以 Configuration Manager 為基礎的記錄檔以檢查錯誤。

「ConfigMgr 站台伺服器 - 通用」下的下列規則分別是以 sender.log、distmgr.log 與 policypv.log 檔案為基礎：

  • ConfigMgr 2007 元件:傳送者無法透過 LAN (標準安全性) 連線至遠端站台
  • ConfigMgr 2007 元件:傳送者無法透過 RAS 連線連接至遠端站台
  • ConfigMgr 2007 元件:傳送者無法透過 LAN (進階安全性) 連線至遠端站台
  • ConfigMgr 2007 元件:Distribution Manager 無法處理封裝
  • ConfigMgr 2007 元件:Distribution Manager 無法插入 SMS Package，因為 CI_Contents 表格中沒有 SDM Type Content
  • ConfigMgr 2007 元件:原則提供者無法從 SMS 站台資料庫取得新的軟體更新原則
  • ConfigMgr 2007 元件:原則提供者無法建立新的軟體更新原則
  • ConfigMgr 2007 元件:原則提供者無法從 SMS 站台資料庫取得新的更新狀態原則
  • ConfigMgr 2007 元件:原則提供者無法建立新的更新狀態原則
  • ConfigMgr 2007 元件:原則提供者無法通知 Hierarchy Manager 原則已發生變更

為了監視這些記錄，必須指定 Configuration Manager 安裝資料夾的位置。若要這樣做，請在站台伺服器上建立 %SMS_INSTALL_DIR_PATH% 系統環境變數，讓使用 Local System 或本機系統管理員使用者內容執行的 MOM 代理程式有足夠的存取權可以在 %SMS_INSTALL_DIR_PATH%\Logs 目錄中記錄檔案。如需有關設定系統環境變數的詳細資訊，請參閱系統環境變數網頁 (http://go.microsoft.com/fwlink/?LinkId=92316) (英文)。

為了讓 Operations Manager 健康狀態代理程式可以使用此系統環境變數，您可能必須重新啟動 Configuration Manager 站台伺服器。

設定代理程式電腦以低權限執行案例

代理程式電腦上的監視功能是由 Operations Manager 2007 Service (HealthService.exe)、Operations Manager 2007 Host (MonitoringHost.exe) 和代理程式動作帳戶提供。在 Microsoft Windows® 2000 上，動作帳戶必須為本機系統管理員群組成員。在 Microsoft Windows™ 2003 上，在某些情況下，您可以為代理程式的代理程式動作帳戶使用低權限的帳戶。然而，要為 Operations Manager 2007 Service 和 Operations Manager 2007 Host 程序使用的動作帳戶和所處的使用者內容設定執行 Configuration Manager 2007 管理組件功能所需的權限，需要在代理程式電腦上進行大量的手動設定。在 Microsoft Windows Server™ 2003 上，代理程式動作帳戶必須具有下列最低使用者權限：

  • Local Users 群組成員
  • Windows 事件日誌存取權限
  • 管理稽核及安全性記錄權限 (SeSecurityPrivilege)
  • 產生安全性稽核權限 (SeAuditPrivilege)
  • 允許本機登入權限 (SeInteractiveLogonRight)

在低權限的案例中，Configuration Manager 2007 管理組件需要用作代理程式動作帳戶的帳戶具有額外權限。下表詳細列出了必須手動設定的存取權限。

Configuration Manager 2007 管理組件所需的存取類型

資源 | 存取類型 | 指示
Windows 事件日誌 | 讀取 | 必須使用本機原則或全域原則為動作帳戶授予「管理稽核及安全性記錄」權限。
SMS 登錄機碼 | 讀取 | HKLM\Software\Microsoft\SMS 將動作帳戶新增到登錄內容並提供所有子機碼都會繼承的讀取權限。
Win32 服務登錄機碼 | 讀取 | HKLM\System\CurrentControlSet\Services 將動作帳戶新增到本機使用者群組。
指令碼產生的暫存檔 | 讀取和寫入 | 在 TMP 變數中針對動作代理程式指定的路徑。對於 Local System，它是 %Windir%\Temp 將動作帳戶新增到本機使用者群組。
SMS 記錄檔 | 讀取 | <ConfigMgrInstallFolder> \Logs 將動作帳戶新增到資料夾屬性。
WMI 命名空間 | 讀取 | root and root\cimv2 不需採取任何動作。
SMS WMI 命名空間 | 讀取 | 不需採取任何動作。
SMS WMI 類別 | 讀取 | SMS_Site SMS_R_System SMS_SiteControlFile SMS_ProviderLocation SMS_SCI_SiteDefinition SMS_SystemResourceList SMS_SystemResourceList SMS_SiteSystemSummarizer 將動作帳戶新增到所有執行個體的類別
預設執行個體的安全性登入權限 | 授予存取 | 對於受管理的 SQL Server 電腦上的預設執行個體，必須為動作帳戶授予安全性登入的「授予」存取權。在 SQL Server Enterprise Manager 中，將動作帳戶新增到下列節點：instancename\Security\Logins
預設執行個體上的主要資料庫存取權限 (識別 SMS 站台資料庫時需要) | 允許 | 對於受管理的 SQL Server 電腦上的預設執行個體，必須為動作帳戶授予主要資料庫的允許存取權限。在 SQL Server Enterprise Manager 中，將動作帳戶新增到下列節點：instancename\Databases\Master\Users 讓所有預設權限與此新使用者保持關聯。
預設執行個體上 SMS 站台資料庫的存取權限 | 允許 | 對於受管理的 SQL Server 電腦上的預設執行個體，必須為動作帳戶授予 SMS 站台資料庫的允許存取權限。在 SQL Server Enterprise Manager 中，將動作帳戶新增到下列節點：instancename\Databases\<SMS site>\Users 讓所有預設權限與此新使用者保持關聯。

請參閱

概念

自訂 Configuration Manager 2007 管理組件
開始使用 Configuration Manager 2007 管理組件
Configuration Manager 2007 管理組件的已知問題
測試與試驗 Configuration Manager 2007 管理組件

其它資源

疑難排解 Configuration Manager 2007 管理組件問題


測試與試驗 Configuration Manager 2007 管理組件

除了《Microsoft Operations Manager 2007 部署手冊》(英文) 中說明的測試管理組件一般建議之外，本節還列出了適用於 Configuration Manager 2007 管理組件的測試工作。如需更多關於測試管理組件的詳細資訊，請參閱 Operations Manager 2007 網頁 (http://go.microsoft.com/fwlink/?LinkID=83259) (英文)。

測試工作

  • 確認 Configuration Manager 2007 電腦群組中已填入執行 Configuration Manager 2007 的電腦。
  • 在啟用相關規則後，請確認 Operations Manager 2007 中的檢視和報告運作正常。其中包括 Configuration Manager 2007 處理速度與 Configuration Manager 2007 待處理項目的相關檢視。
  • 依照預設，Configuration Manager 2007 管理組件中會停用部分與其他管理組件 (例如 IIS 和 SQL Server 管理組件) 相關的規則。請視您已部署的額外管理組件而定，檢閱這些停用的規則，以識別任何可能要在您的環境中啟用的規則。
  • 依照預設，會停用所有效能測量規則，將對代理程式 CPU、記憶體和網路資源的影響降到最低。您可以啟用這些規則，進一步進行監視。
  • 在 Configuration Manager 2007 提供者電腦、Configuration Manager 2007 站台伺服器上執行，或存取 Configuration Manager 2007 站台資料庫的部分 Configuration Manager 2007 指令碼，不會以無代理程式模式執行。確認 Configuration Manager 2007 Provider 與 Configuration Manager 2007 Site Database Server 電腦群組中的所有電腦都已設為受代理程式管理的電腦。此外，由於部分指令碼可以做為事件 Proxy，請確認這些代理程式已設為啟用 Proxy 處理。
  • 若要支援 SQL 叢集，針對 ConfigMgr 站台資料庫執行的所有指令碼都要從站台伺服器執行。確認指令碼沒有產生任何錯誤事件或警示。

請參閱

概念

自訂 Configuration Manager 2007 管理組件
部署 Operations Manager 2007 代理程式
Configuration Manager 2007 管理組件的已知問題

其它資源

疑難排解 Configuration Manager 2007 管理組件問題


試驗測試 Configuration Manager 2007 管理組件

除了《Microsoft Operations Manager 2007 部署手冊》(英文) 中說明的測試管理組件一般建議之外，本節還列出了適用於 Configuration Manager 2007 管理組件的試驗工作。如需更多關於測試管理組件的詳細資訊，請參閱 Operations Manager 2007 網頁 (http://go.microsoft.com/fwlink/?LinkID=83259) (英文)。

試驗測試工作

  • 確認 Configuration Manager 2007 管理組件的部署或從前版升級程序已順利完成。
  • 在主控台中使用「撰寫中」模式確認並編輯適用於您環境的自訂效能閾值。選取領域或搜尋適當的規則。
  • 於評估這些規則對 Operations Manager 2007 效能所造成之影響的階段中啟用效能規則。
  • 確認 Configuration Manager 2007 電腦群組中填入了執行 Configuration Manager 2007 的電腦。
  • 在啟用相關規則後，請確認 Operations Manager 2007 中的檢視和報告運作正常。其中包括 Configuration Manager 2007 處理速度、處理總數和 Configuration Manager 2007 待處理項目的相關檢視。
  • 依照預設，部分與其他管理組件相關的規則會停用。請視您已部署的額外管理組件而定，檢閱停用的規則，以識別任何可能要在您的環境中啟用的規則。
  • 依照預設，會停用部分效能規則，將對代理程式 CPU、記憶體和網路資源的影響降到最低。您可以啟用這些規則，進一步監視代理程式。
  • 確認未產生 Configuration Manager 2007 指令碼錯誤事件與警示。這些事件與警示通常代表指令碼存取權限問題。
  • 確認 Operations Manager 和 SQL Server 的大小對於您的實際執行負載已足夠。
  • 確認操作處理和人員需求。
  • 確認通知功能已正常運作。
  • 確認 Operations Manager 2007 使用的權限足夠正常運作而不會過高。
  • 動作帳戶代理程式只能由 LocalSystem 帳戶執行。若動作帳戶代理程式不是使用 LocalSystem 權限執行，請確保執行代理程式的帳戶具有基本安全性權限。如需更多資訊，請參閱本手冊部署 Operations Manager 2007 代理程式一節中的＜設定代理程式電腦以低權限執行案例＞。
  • 確認 Configuration Manager 2007 Server 與 Configuration Manager 2007 Client 角色出現在 [電腦狀態] 檢視中。按一下持有任何一個角色的電腦，並檢查屬性是否顯示於詳細資料窗格中。
  • 在 [電腦狀態] 檢視中，按一下 ConfigMgr Server 與 ConfigMgr Client 執行個體，並檢查其 [角色] 是否已顯示於詳細資料窗格中。
  • 在 [電腦狀態] 檢視中，按兩下 ConfigMgr Server 與 ConfigMgr Client 執行個體，並在 [狀態] 檢視詳細資料窗格檢視其屬性。
  • 確認站台與站台階層狀態檢視已正常運作。
  • 按下任何 Configuration Manager 2007 系統管理員主控台工作，確認工作正常進行。若工作無法執行，請檢查是否已安裝 Configuration Manager 2007 系統管理員主控台，以及已登入的使用者是否有足夠的權限可以執行主控台工作。
  • 檢查 [站台階層圖表]。確認所有於 Configuration Manager 2007 提供者本機安裝 Operations Manager 2007 代理程式的站台之站台系統都已顯示。如果某個站台系統未顯示，請檢查 Configuration Manager 2007 系統管理員主控台，查看站台是否已探索站台系統並顯示於 [All Systems] 集合中。此外，請您也檢查是否已經為每部伺服器輸入 FQDN。

完成試驗測試與微調之後，請將預設管理組件或您建立的自訂 Configuration Manager 2007 管理組件匯出，以備份您所做的設定。

請參閱

概念

自訂 Configuration Manager 2007 管理組件
部署 Operations Manager 2007 代理程式
Configuration Manager 2007 管理組件的已知問題

其它資源

疑難排解 Configuration Manager 2007 管理組件問題


自訂 Configuration Manager 2007 管理組件

為達到監控的最佳化，Configuration Manager 2007 管理組件可以根據您組織的業務需求加以自訂。如果現有的規則不符合您組織的需要，您可以修改規則或建立新規則。

注意 進行變更之前，請務必備份 Configuration Manager 2007 管理組件。Operations Manager 2007 管理組件匯出精靈可以讓您備份預設的管理組件或未封裝的自訂管理組件。

自訂可以包括下列任何項目：

  • 使用覆寫啟用與停用規則。
  • 建立新規則與監控。
  • 修改警示條件、警示嚴重性和警示抑制。
  • 為監控設定自訂閾值。所有效能閾值監控器皆可設定。如果預設閾值並未最佳化，您可能會收到不必要的警示，而如果設定了對您的環境而言過高的閾值，就不會收到警示。
  • 在規則與監控上使用覆寫來設定收件匣監控閾值與輪詢間隔。
  • 新增收件匣自訂指令碼型的監控事件規則。若要新增收件匣監控規則，請在預設管理組件或自訂管理組件中建立新規則，然後為指令碼輸入參數 (FileCountThreshold 和 InboxDirectoryName) 建立覆寫和排程。
  • 使用覆寫為效能測量設定輪詢間隔。
  • 將內容新增到公司知識。
  • 變更或新增回應到規則或監控，以自訂對警示的回應。
  • 在代理程式上啟用效能測量規則會產生大量的資料，而且可能會導致發生效能問題。效能測量規則依預設會停用，讓您決定是否可以接受可能產生的效能影響。請分批檢閱效能規則並加以啟用，讓您可以評估這些規則對 Operations Manager 2007 效能的影響，包括資料庫的大小。
  • 檢閱規則在您環境中的適用性。依照預設，部分與其他管理組件相關的規則會停用。請視您已部署的額外管理組件而定，檢閱停用的規則，以識別任何可能要在您的環境中啟用的規則。

如需更多關於管理組件自訂和如何匯出管理組件自訂的資訊，請參閱 Operations Manager 2007 網頁 (http://go.microsoft.com/fwlink/?LinkId=100980) (英文) 中的＜關於 Operations Manager 2007 中的管理組件＞和＜如何匯出管理組件自訂＞主題。

收件匣監控

Operations Manager 2007 匯出精靈能讓您在進行進一步變更之前，儲存預設管理組件或您建立之任何自訂管理組件中的變更。

設定收件匣監控規則

若要部署這些規則到中央、主要和次要站台伺服器，您必須在管理組件中根據 [Microsoft ConfigMgr 2007 站台伺服器 - 通用] 中的規則建立新規則。您稍後可以將這些規則的目標設定為適當的站台伺服器類別、修改閾值，以及啟用規則。

  • ConfigMgr 收件匣:監控收件匣
  • ConfigMgr 收件匣:監控收件匣指令碼錯誤
  • ConfigMgr 收件匣:閾值已超過

[ConfigMgr 收件匣:閾值已超過] 事件處理規則會監控來自 ConfigMgr:監控收件匣指令碼錯誤之指令碼的事件。會為每個超過指定閾值計數的收件匣產生唯一的警示。

此指令碼的預設閾值設定為收件匣中存在 10,000 個檔案。您可以在此指令碼或任何其他指令碼參數的預設或自訂管理組件中為此值建立覆寫。如果超過，會產生「閾值已超過」事件。您可以計算每日伺服器上每個正常運作處理序的預期負載以修改閾值設定，然後新增可接受的緩衝區百分比。收件匣監控規則依預設每天執行一次，從 01:00 開始以 15 分鐘為一單位。若要將效能影響降至最低，建議您維持此間隔，或調整以將任何收件匣監控規則之間重疊的指令碼執行情況降至最低。

下表列出了收件匣監控規則、預設閾值和 SMS Executive 提供者下監控的收件匣。

SMS Executive 收件匣監控

收件匣監控規則名稱 | 預設閾值 | 收件匣名稱
ConfigMgr 收件匣:監控收件匣指令碼錯誤 | n/a | n/a
ConfigMgr 收件匣:閾值已超過 | n/a | n/a
ConfigMgr 收件匣:監控<收件匣目錄名稱> | 10000 | Inboxes\auth\dataldr.box

覆寫收件匣監控事件規則的程序

在您覆寫收件匣監控事件規則之前，Operations Manager 2007 站台伺服器必須探索類型為「Microsoft Configuration Manager 2007 站台伺服器」的 Configuration Manager 2007 站台伺服器物件。

覆寫收件匣監控事件規則

  1. 在 [System Center Operations Manager 2007] 主控台中，按一下 [撰寫中]。

  2. 瀏覽到 [撰寫中] > [管理組件物件] > [規則]。

  3. 若 [尋找] 文字方塊無法使用，請瀏覽 [檢視]，然後按一下 [尋找]。

  4. 按一下 [變更領域]，然後設定 [Microsoft ConfigMgr 2007 站台伺服器] 的領域。

  5. 在要修改的適當 ConfigMgr 收件匣監控事件規則上按一下滑鼠右鍵，選取 [覆寫規則]，然後按一下 [針對以下類型的所有物件:Microsoft ConfigMgr 2007 站台伺服器]。

  6. 在 [覆寫內容] 中，選取 [已啟用] 覆寫核取方塊，然後將 [覆寫設定] 設定為 [真] 以啟用規則，或設定為 [假] 以停用規則。

  7. 在 [覆寫內容] 中，選取覆寫核取方塊，然後將 [覆寫設定] 設定為想要的值。按一下 [確定]。修改的閾值會分散到伺服器。

定義 SMS Admin UI 變數以支援主控台工作

若 Configuration Manager 2007 站台伺服器或 Admin UI 與已匯入 Configuration Manager 2007 管理的 Operations Manager 2007 安裝共存，則 Operations Manager 主控台將能夠從工作窗格啟動下列 Configuration Manager 2007 UI 元件：

  • 資源總管
  • Configuration Manager 主控台
  • 服務管理員
  • 狀態訊息

為啟動這些應用程式，會建立 SMS_ADMIN_UI_PATH 系統環境變數。此環境變數指向包含 Configuration Manager 主控台的目錄，預設是 [ConfigMgrInstallationPath] \ AdminUI \ bin \ i386。

啟用 Configuration Manager 2007 規則

根據預設，特定管理組件規則 (包括效能測量計數器與監控線上醒機功能的規則) 是停用的。若要使用這些規則，必須將它們啟用。

  • 在 Configuration Manager 2007 管理組件中，線上醒機規則預設是停用的，包括：
  • ConfigMgr 2007 效能閾值:過去 1 小時內站台伺服器收件匣 WOLCMGR.box Backlog > 20
  • ConfigMgr 2007 效能閾值:過去 1 小時內站台伺服器收件匣 WOLCMGR.box\data Backlog > 100
  • ConfigMgr 2007 效能閾值:過去 15 分鐘內 SMS 線上醒機通訊管理員的失敗封包總數 > 100
  • ConfigMgr 2007 效能閾值:過去 3 小時內 SMS 線上醒機通訊管理員的擱置中要求總數 > 10,000
  • ConfigMgr 2007 遺失狀態:Patch Management 同步處理元件已成功下載類別目錄，並使用新的類別目錄版本更新發佈點。
附註
「ConfigMgr 2007 遺失狀態:Patch Management 同步處理元件已成功下載類別目錄，並使用新的類別目錄版本更新發佈點」規則只有在 Operations Manager 2007 SP1 與更新版本中受支援。

若要啟用已停用的管理組件規則，請使用下列程序。

程序

啟用已停用的管理組件規則

  1. 在操作主控台中，按一下 [撰寫中]。

  2. 在瀏覽窗格中，瀏覽到 [撰寫中] > [管理組件物件]，然後按一下 [規則]。

  3. 在規則窗格中，搜尋要啟用的規則。若規則清單上方的 [尋找] 列無法使用，請瀏覽 [檢視]，然後按一下 [尋找]。

  4. 在要啟用之規則的名稱上按一下滑鼠右鍵，瀏覽到 [覆寫] > [覆寫規則]，然後按一下要由此規則監控的物件集合。

  5. 將 [Enabled] 屬性設定為 [真]，然後根據您環境需要修改任何閾值。按一下 [確定]。

請參閱

概念

開始使用 Configuration Manager 2007 管理組件
Configuration Manager 2007 的管理組件監視案例
支援的 Configuration Manager 2007 管理組件設定
測試與試驗 Configuration Manager 2007 管理組件

其它資源

Configuration Manager 2007 管理組件的參考資料
疑難排解 Configuration Manager 2007 管理組件問題


Configuration Manager 2007 與 Operations Manager 2007 的整合

Configuration Manager 2007 是透過 Operations Manager 主控台工作與 Operations Manager 主控台整合，這些主控台工作可啟動 Configuration Manager 系統管理員主控台元件。

它也支援在軟體發佈與軟體更新程式執行期間，在執行 Operations Manager 2007 代理程式的 Configuration Manager 用戶端上啟用維護模式。進行站台備份期間也會啟用維護模式，但此運作方式無法設定。

Operations Manager 2007 主控台工作

若要執行 Configuration Manager 2007 系統管理員主控台工作，Configuration Manager 2007 系統管理員主控台必須安裝在與 Operations Manager 2007 操作主控台相同的電腦上。您必須將系統環境變數 SMS_ADMIN_UI_PATH 定義為包含 Configuration Manager 2007 主控台程式之資料夾的路徑。如需有關設定系統環境變數的詳細資訊，請參閱系統環境變數網頁 (http://go.microsoft.com/fwlink/?LinkId=92316) (英文)。

您可以從 Operations Manager 主控台啟動下列 Configuration Manager 2007 工作。

工作 | 說明
ConfigMgr 2007 系統管理員主控台 | 開啟導向至目前選取電腦的 Configuration Manager 2007 系統管理員主控台。適用於持有 Configuration Manager 2007 站台伺服器角色的電腦。
所有 ConfigMgr 2007 狀態訊息 | 提示輸入電腦的站台伺服器、開啟 MMC 視窗，並執行狀態訊息查詢以傳回所有與目前所選取電腦相關的狀態訊息。適用於所有系統。
ConfigMgr 2007 服務管理員 | 開啟導向至目前選取電腦的 Configuration Manager 2007 服務管理員。適用於持有 Configuration Manager 2007 站台伺服器角色的電腦。
ConfigMgr 2007 資源總管 | 提示輸入電腦的站台伺服器，並開啟 MMC 視窗 (其中 Configuration Manager 2007 資源總管會顯示目前所選取電腦的資料)。適用於所有系統。

Configuration Manager 2007 的維護模式

System Center Configuration Manager 2007 透過其軟體發佈與軟體更新功能支援 Operations Manager 2007 的維護模式。透過將 MOM 代理程式切換至維護模式，可以在執行 Configuration Manager 用戶端的電腦上抑制警示。

當 Configuration Manager 2007 將軟體發佈到電腦時，通常需要暫時停用目標電腦產生的 Operations Manager 規則型警示。例如，將 Hotfix 和安全性修補程式部署到伺服器，可能需要關閉執行緒和服務。如果這些伺服器上的執行緒或服務是由管理組件監控，系統可能會產生大量 Operations Manager 警示，導致 Operations Manager 伺服器超載。

[Disable MOM alerts while this program runs] 核取方塊會暫停 Operations Manager 警示，直到軟體發佈結束為止。Configuration Manager 2007 系統管理員可以在 Configuration Manager 封裝程式內容中，設定此核取方塊。設定此選項會在用戶端電腦執行該程式時，抑制以用戶端電腦為目標的所有管理組件的 Operations Manager 警示。系統會使用最大允許執行時間做為維護模式期間的逾時。

針對 Configuration Manager 軟體更新啟用維護模式

當軟體更新在用戶端電腦上執行時，由 Configuration Manager 2007 發佈的軟體更新可能會產生警示。為避免執行規劃的維護作業時收到警示，您可以在執行軟體更新期間停用警示。

若要在執行軟體更新時停用 Operations Manager 警示，請使用下列程序。

程序

在執行軟體更新時停用 Operations Manager 警示

  1. 在 Configuration Manager 2007 主控台中，瀏覽到 [System Center Configuration Management] / [Site Database - <站台伺服器名稱>] / [Computer Management] / [Software Updates] / [Deployment Management]。

  2. 在更新名稱上按一下滑鼠右鍵，然後按一下 [Properties]。

  3. 在 [Program Properties] 對話方塊中，按一下 [Event Generation] 索引標籤。

  4. 選取 [Disable Operations Manager alerts while software updates run]，然後按一下 [OK]。

啟用 Configuration Manager 軟體更新的維護模式後，用戶端電腦會在 Configuration Manager 更新發佈及執行時進入維護模式。

針對 Configuration Manager 軟體發佈啟用維護模式

當軟體發佈的軟體發佈程式在用戶端電腦上執行時，由 Configuration Manager 2007 發佈的軟體可能會產生警示。為避免執行規劃的維護作業時收到警示，您可以在執行軟體發佈程式期間停用警示。

若要在執行此軟體發佈程式時停用 Operations Manager 警示，請使用下列程序。

程序

在執行軟體發佈程式時停用 Operations Manager 警示

  1. 在 Configuration Manager 2007 主控台中，瀏覽到 [System Center Configuration Management] / [Site Database - <站台伺服器名稱>] / [Computer Management] / [Software Distribution] / [Packages] / <封裝名稱> / [Program]。

  2. 在詳細資料窗格中，以滑鼠右鍵按一下程式名稱，然後按一下 [Properties]。

  3. 在 [Program Properties] 對話方塊中，按一下 [MOM Maintenance Mode] 索引標籤。

  4. 選取 [Disable Operations Manager alerts while this program runs]，然後按一下 [OK]。

啟用 Configuration Manager 程式的維護模式後，用戶端電腦會在 Configuration Manager 封裝發佈及執行時進入維護模式。

附註
維護模式的逾時時間可於 [Program Properties] 對話方塊的 [Requirements] 索引標籤選擇 [Maximum allowed runtime] 屬性加以設定。

為 Configuration Manager 2007 程式失敗產生警示

若由 Configuration Manager 2007 發佈的軟體無法在用戶端電腦上安裝，可能必須向系統管理員發出警示。

若要在軟體發佈程式失敗時產生 Operations Manager 警示，請執行下列程序。

程序

在軟體發佈程式失敗時產生 Operations Manager 警示

  1. 在 Configuration Manager 2007 主控台中，瀏覽到 [System Center Configuration Management] / [Site Database - <站台伺服器名稱>] / [Computer Management] / [Software Distribution] / [Packages] / <封裝名稱> / [Program]。

  2. 在詳細資料窗格中，以滑鼠右鍵按一下程式名稱，然後按一下 [Properties]。

  3. 在 [Program Properties] 對話方塊中，按一下 [MOM Maintenance Mode] 索引標籤。

  4. 選取 [Generate Operations Manager alert if this program fails]，然後按一下 [OK]。

啟用此屬性之後，若軟體程式無法執行，程式將會傳送 Operations Manager 警示。

為 Configuration Manager 2007 程式失敗產生警示

若由 Configuration Manager 2007 發佈的軟體無法在用戶端電腦上安裝，可能必須向系統管理員發出警示。

若要在軟體發佈程式失敗時產生 Operations Manager 警示，請執行下列程序。

程序

在軟體更新安裝失敗時產生 Operations Manager 警示

  1. 在 Configuration Manager 2007 主控台中，瀏覽到 [System Center Configuration Management] / [Site Database - <站台伺服器名稱>] / [Computer Management] / [Software Updates] / [Deployment]。

  2. 在詳細資料窗格中，以滑鼠右鍵按一下更新名稱，然後按一下 [Properties]。

  3. 在 [Program Properties] 對話方塊中，按一下 [MOM Maintenance Mode] 索引標籤。

  4. 選取 [Generate Operations Manager alert when a software update installation fails]，然後按一下 [OK]。

啟用此屬性之後，當軟體更新安裝失敗時，系統會傳送 Operations Manager 警示。

請參閱

概念

Configuration Manager 2007 管理組件的每日工作
Configuration Manager 2007 管理組件的每週工作
Configuration Manager 2007 管理組件的每月工作

其它資源

執行 Configuration Manager 2007 管理組件的操作工作
Configuration Manager 2007 管理組件的參考資料
疑難排解 Configuration Manager 2007 管理組件問題


Configuration Manager 2007 的管理組件監視案例

Microsoft® System Center Configuration Manager 2007 管理組件提供 Configuration Manager 2007 監視的加強新功能。下列章節將說明 Configuration Manager 2007 管理組件支援的主要案例，加上個別功能的說明。

服務可用性

服務探索

可用性監視

電腦狀態監視

站台階層狀態監視

站台狀態監視

無代理程式監視支援

效能閾值監視

效能監視

重大 Configuration Manager 狀態訊息監視

站台系統狀態監視

執行損毀傾印監視

待處理項目監視

一般健康狀態監視

Configuration Manager 軟體更新管理監視

Configuration Manager 站台備份監視

所有警示產品知識內容

所有 Configuration Manager 伺服器和用戶端角色電腦群組

擴充監視

軟體發佈程式執行狀態

Configuration Manager 工作監視

元件記錄檔監視

Configuration Manager 2007 收件匣監視

服務可用性

服務可用性同時利用 System Center Operations Manager 2007 的服務可用性功能，以及 NT 系統事件記錄中的服務控制管理員事件，監視 Configuration Manager 服務的可用性。當下列情況發生時，服務可用性監視會產生警示：

  • 當 Configuration Manager 站台系統上的 Configuration Manager 服務停止時，就會產生警示。
  • 當重要 Configuration Manager 依存服務，例如 Windows Management Instrumentation (WMI)，在 Configuration Manager 站台系統上停止或無法啟動時，就會產生警示。
  • 當其他 Configuration Manager 依存服務，例如 Microsoft SQL Server™、Internet Information Services (IIS) 及背景智慧型傳送服務 (BITS)，在 Configuration Manager 站台系統上停止或無法啟動時，就會產生警示。
  • 當 Configuration Manager 站台備份服務啟動並停止時，就會產生警示，這樣您才能監視備份期間，並將其他 Configuration Manager 服務和 Configuration Manager 站台備份的停止事件建立關聯。

服務探索

服務探索是在受管理的電腦上探索資料、伺服器角色和元件的程序。服務探索會傳回 Configuration Manager 伺服器和 Configuration Manager 用戶端的相關資訊，並且支援在狀態監視檢視中，呈現 Configuration Manager 伺服器和 Configuration Manager 用戶端角色。

系統會蒐集伺服器特定的服務探索資料，並在代理程式部署管理組件後，開始在 System Center 操作主控台中顯示資料。在系統首次蒐集服務探索資料後，才能使用需要辨識角色、電腦群組以及特定工作的目標電腦的功能。

Configuration Manager 管理組件使用下列事件處理規則：

  • ConfigMgr 2007 Service Discovery

啟動適當的服務探索指令碼：

  • ConfigMgr 2007 Service Discovery - Server
  • ConfigMgr 2007 Service Discovery - Client
  • 指令碼預設會使用非同步的計時提供者，每 24 小時蒐集一次服務探索資料。

可用性監視報告

Configuration Manager 2007 管理組件包含下列可用性報告，可監視下列伺服器角色的活動訊號：

  • 伺服器可用性
  • 發佈點可用性
  • 管理點可用性
  • PXE 服務點可用性
  • 站台伺服器可用性
  • 軟體更新點可用性
  • 系統健康狀態驗證可用性
  • 狀態移轉點可用性
  • 站台資料庫伺服器可用性

針對 OperationsManager 資料庫執行的所有報告，您都可以指定其報告期間。

如需伺服器可用性報告的相關資訊，請參閱 Configuration Manager 2007 管理組件的報告。

伺服器角色可用性監視

系統會監視下列角色的可用性：

  • 管理點
  • NLB 管理點
  • 裝置管理點
  • 系統健康狀態驗證
  • 狀態移轉點
  • PXE 服務點
  • 軟體更新點
  • 發佈點
  • 站台資料庫伺服器

元件可用性監視

系統會監視下列會產生定期活動訊號以報告其可用性狀態的元件：

  • INBOX MANAGER
  • INBOX MONITOR
  • SITE COMPONENT MANAGER
  • MP CONTROL MANAGER
  • MP FILE DISPATCH MANAGER
  • OUTBOX MONITOR
  • WAKEONLAN COMMUNICATION MANAGER
  • WAKEONLAN MANAGER
  • WSUS CONFIGURATION MANAGER
  • WSUS SYNC MANAGER
  • WSUS CONTROL MANAGER
  • DATABASE NOTIFICATION MONITOR
  • OFFER STATUS SUMMARIZER
  • COMPONENT STATUS SUMMARIZER
  • SITE SYSTEM STATUS SUMMARIZER
  • COMPONENT MONITOR
  • STATE MIGRATION POINT
  • PXE SERVICE POINT

電腦狀態監視

電腦狀態監視會以列表方式提供所有 Configuration Manager 伺服器與用戶端的健康狀態。伺服器角色與元件是透過服務探索來管理。元件健全狀況狀態是由一組規則與監視管理。

下方表格依色彩顯示所監視 Configuration Manager 元件的健全狀況狀態。

Configuration Manager 伺服器狀態監視

ConfigMgr 伺服器元件 | 綠色 (成功) | 黃色 (警告) | 紅色 (重大)
站台伺服器 (SS) | 是 | 是 | 是
管理點 (MP) | 是 | 是 | 是
站台資料庫 (DB) | 是 | 是 | 是
發佈點 (DP) | 是 |  | 是
伺服器定位器點 (SLP) | 是 |  | 是
報告點 (RP) | 是 |  | 是
狀態移轉點 (SMP) | 是 | 是 | 是
PXE 服務點 (PSP) | 是 | 是 | 是
後援狀態點 (FSP) | 是 | 是 | 是
系統健康狀態驗證 (SHV) | 是 | 是 | 是
軟體更新點 (SUP) | 是 | 是 | 是
提供者 |  |  |
效能 | 是 | 是 | 是

Configuration Manager 用戶端狀態監視

ConfigMgr 用戶端元件 | 綠色 (成功) | 黃色 (警告) | 紅色 (重大)
用戶端服務 | 是 |  | 是

站台階層狀態監視

站台階層狀態監視會以列表方式提供站台階層中所有 Configuration Manager 2007 受管理系統的健康狀態。系統健全狀況狀態是由一組規則與監視管理。

下方表格依色彩顯示所監視 Configuration Manager 系統的健全狀況狀態。

Configuration Manager 站台階層狀態監視

ConfigMgr 伺服器元件 | 綠色 (成功) | 黃色 (警告) | 紅色 (重大)
可用性 | 是 | 是 | 是
效能 | 是 | 是 | 是

站台狀態監視

站台狀態監視會以列表方式提供所有 Configuration Manager 受管理伺服器的健康狀態。站台健全狀況狀態是由一組規則與監視管理。

下方表格依色彩顯示所監視 Configuration Manager 站台狀態的健全狀況狀態。

Configuration Manager 站台狀態監視

ConfigMgr 伺服器元件 | 綠色 (成功) | 黃色 (警告) | 紅色 (重大)
可用性 | 是 | 是 | 是
效能 | 是 | 是 | 是

無代理程式監視支援

Configuration Manager 管理組件支援對無代理程式的受管理電腦進行監視，但下列功能除外：

  • 重大 Configuration Manager 狀態訊息監視
  • 站台系統狀態監視

下列指令碼支援上述功能：

  • ConfigMgr 2007 Monitor Collection Evaluation Tasks
  • ConfigMgr 2007 Monitor Site Maintenance Tasks
  • ConfigMgr 2007 Monitor Site System Summarizer
  • ConfigMgr 2007 Monitor SMS Executive Crash Dumps
  • ConfigMgr 2007 Monitor SMS Status Messages
  • ConfigMgr 2007 Monitor State Message Summary Tasks

這些指令碼必須在本機上執行，以存取 Configuration Manager 資源。如果指令碼無法存取資源，便會產生指令碼錯誤事件與警示。

效能閾值監視

效能等級降低會造成延遲，並影響客戶服務等級協定 (SLA) (以時間計算)、效能及資料精確度等層面。因此，偵測並解決 Configuration Manager 基礎結構中的重大效能問題，是重要的議題。效能閾值監視功能，可以在受監視的條件超過特定等級時產生警示：

  • Configuration Manager 站台系統上與 CPU、分頁檔以及記憶體相關的一般電腦健康狀態標準。
  • Configuration Manager 站台伺服器收件匣中 Configuration Manager 檔案的總數，例如排程器作業、傳送要求、軟體計量記錄、探索資料記錄 (DDR)，以及軟體清查與硬體清查記錄。
  • Configuration Manager 管理點訊息佇列中與狀態訊息、DDR、軟體清查，以及硬體清查相關的 Configuration Manager 訊息總數。
  • SHV 回應與條件。
  • SMS 寄件匣中的檔案。
  • PSP 要求。
  • SMP 用戶端與磁碟空間總數。
  • WOL 封包。

效能監視

效能監視能讓您觀察待處理項目、處理速度，以及主要 Configuration Manager 物件總數的趨勢，以協助辨識並主動解決問題。效能趨勢透過使用 Operations Manager 2007 檢視與報表，以圖表形式監視下列趨勢：

  • Configuration Manager 站台伺服器上收件匣中與排程器作業、傳送要求、軟體計量記錄、DDR、硬體清查、軟體清查、WOL 封包，以及狀態訊息相關的待處理項目檔案。
  • Configuration Manager 站台伺服器上排程器作業、傳送要求、軟體計量記錄、DDR、硬體清查、軟體清查、WOL 封包、SUP 更新，以及狀態訊息的處理速率。
  • Configuration Manager 站台伺服器上排程器作業、傳送要求、軟體計量記錄、DDR、硬體清查、軟體清查、WOL 封包、SUP 更新，以及狀況與狀態訊息的總數。
  • Configuration Manager 管理點伺服器訊息佇列上與 DDR、硬體清查、軟體清查、軟體計量、狀況與狀態訊息，以及其他 Configuration Manager 物件相關的訊息待處理項目。
  • Configuration Manager 管理點伺服器訊息佇列上 DDR、硬體清查、軟體清查、軟體計量、狀況與狀態訊息、SDM 封包要求，以及其他 Configuration Manager 物件的處理速度。
  • Configuration Manager 管理點伺服器訊息佇列上的 DDR、硬體清查、軟體清查、轉送、SDM 封裝要求，以及狀態訊息總數。
  • Configuration Manager 站台系統上與 CPU、分頁檔以及記憶體相關的電腦健康狀態標準。
  • 正在執行的 Configuration Manager Executive 執行緒總數。
  • 向 IIS 發出 ISAPI 擴充程式要求的速度。
  • 站台系統上寄件匣中的待處理項目。
  • SMS 伺服器可用性要求。
  • SHV 狀況與 SoH 要求。
  • PSP 要求處理。
  • SMP 用戶端狀態處理與可用磁碟空間。
  • Configuration Manager 裝置管理點伺服器訊息佇列上 DDR、硬體清查、軟體清查、軟體計量、狀態訊息，以及其他 Configuration Manager 物件的處理速度。

重大 Configuration Manager 狀態訊息監視

Configuration Manager 基礎結構會產生 Configuration Manager 狀態訊息。辨識與伺服器相關的重大 Configuration Manager 狀態訊息，並即時解決問題，是重要的議題。這些訊息通常代表可用性、效能、安全性、設定，以及 Configuration Manager 基礎結構的整體健康狀態出了問題。

當系統偵測到 Configuration Manager 的重大狀態訊息時 (例如元件安裝、資料庫連線能力以及站台連線能力)，重大 Configuration Manager 狀態訊息監視會產生警示。每個半點與整點時都會掃描 Configuration Manager 站台資料庫內是否出現重大 Configuration Manager 狀態訊息。

站台系統狀態監視

Configuration Manager 會透過其站台系統狀態摘要器，定期監視其站台系統的基本健康狀態，站台系統狀態摘要器每小時 (整點) 會輪詢一次 Configuration Manager 站台系統。您必須迅速因應處理此一狀態，防止 Configuration Manager 功能降低，才能受益於此功能。站台系統狀態監視提供監控的能力，並在偵測到 Configuration Manager 站台系統健康狀態的重大 Configuration Manager 站台系統摘要器狀態時，產生警示。某些監視的狀態包含當機的 Configuration Manager 站台系統、用盡資料庫空間或記錄檔空間的 SQL Sever，以及用盡 NTFS 磁碟機上實體磁碟空間的 Configuration Manager 站台系統。

執行損毀傾印監視

Configuration Manager Executive 服務失敗會影響 Configuration Manager 可用性，因此瞭解損毀傾印發生的時機並調查根本起因，是重要的議題。當 SMS Executive 服務失敗時，會在 <ConfigMgrInstallationPath>\Logs\CrashDumps 目錄下，建立損毀傾印記錄檔子目錄。子目錄建立時，系統會進行監視，並為依賴 SMS Executive 服務的任何 Configuration Manager 伺服器角色產生警示。

Configuration Manager 2007 Monitor SMS Executive Crash Dumps 指令碼只會報告最近發生的損毀傾印。無論損毀傾印發生在何時，從指令碼首次執行，到 SMS Executive 解除安裝並於稍後重新安裝，都適用於此規則。

相關的規則以 [以 SMS Executive 為基礎的 Microsoft Configuration Manager 2007 元件伺服器] 類別為目標：

  • ConfigMgr 2007 損毀傾印：監視 SMS Executive

ConfigMgr 2007 損毀傾印：監視 SMS Executive每隔 60 分鐘會啟動指令碼 (於 00:10 同步)。摘要資訊會於規則的 [Knowledge] 內容頁中提供。

  • ConfigMgr 2007 損毀傾印：監視 SMS Executive 指令碼錯誤

ConfigMgr 2007 損毀傾印：監視 SMS Executive 指令碼錯誤會監視並警示可能發生的任何指令碼錯誤事件。只有一個指令碼錯誤事件 (其編號為 1102)，它會報告所有指令碼錯誤。警示解決方式的相關資訊會於規則的 [Knowledge] 內容頁中提供。

  • ConfigMgr 2007 損毀傾印：SMS Executive 損毀

ConfigMgr 2007 損毀傾印：SMS Executive 損毀會監視並警示損毀傾印事件。警示解決方式的相關資訊會於規則的 [Knowledge] 內容頁中提供。

待處理項目監視

待處理項目會造成延遲，影響客戶 SLA (以時間計算)、效能以及資料精確度等層面。因此，立即偵測並解決 Configuration Manager 基礎結構中的重大效能問題，是重要的議題。當待處理項目於指定的時間內有以下項目超過閾值時，系統會產生警示：

  • Configuration Manager 站台伺服器收件匣中 Configuration Manager 檔案的總數，例如排程器作業、傳送要求、軟體計量記錄、DDR、軟體清查與硬體清查記錄、WOL 要求，以及狀況與狀態訊息。
  • Configuration Manager 站台伺服器佇列中 Configuration Manager 物件的總數，例如排程器作業、傳送要求、軟體計量記錄、DDR、軟體清查與硬體清查記錄、WOL 要求，以及狀態訊息。
  • Configuration Manager 管理點訊息佇列中與狀態訊息、DDR、軟體清查，以及硬體清查相關的 Configuration Manager 訊息總數。
  • 站台系統寄件匣中檔案的總數，例如軟體計量記錄、DDR、軟體清查與硬體清查記錄，以及狀況與狀態訊息。

一般健康狀態監視

當 Configuration Manager 伺服器上的健康狀態標準，於一段時間內超過特定閾值時，一般健康狀態監視便會產生警示。一般健康狀態監視會檢查下列標準：

  • 過去 3 小時內的處理器時間持續達 95%
    • Smsexec
    • Ccmexec
    • 總數
  • 過去 3 小時內的分頁檔使用量持續達 98%

Configuration Manager 軟體更新管理監視

Configuration Manager 系統管理員依賴 Configuration Manager 軟體更新管理功能，讓企業中現有的用戶端及伺服器電腦，能隨時保持最新的安全性更新。修補管理監視會偵測 Configuration Manager 軟體更新管理處理與設定中的任何失敗。當系統偵測到發生下列情況時，Configuration Manager 軟體更新管理監視便會產生警示：

  • 無法設定 WSUS 伺服器。
  • Configuration Manager 無法訂閱來自 WSUS 伺服器的更新。
  • Configuration Manager 軟體更新管理同步處理程序失敗。
  • Configuration Manager 軟體更新管理程序無法使用更新來更新 Configuration Manager 發佈點。

Configuration Manager 站台備份監視

瞭解 Configuration Manager 備份開始、完成或失敗的時間點，能夠協助 Configuration Manager 系統管理員稽核備份活動。您可以排程 Configuration Manager 備份定期執行，備份 Configuration Manager 的資料、原則及設定。

您必須監視此備份程序的失敗事件並採取修正動作。即使 Configuration Manager 備份成功，因為此程序停止後會啟動 SMS Site Component Manager 與 SMS Executive，所以也會影響服務的可用性。監視 Configuration Manager 備份能協助追蹤這些服務中已知的停機，因為在備份程序進行時不會出現關於這些服務停止的警示。下列規則支援監視 Configuration Manager 站台備份：

  • ConfigMgr 2007 狀態:站台備份已成功完成
  • ConfigMgr 2007 狀態:站台備份失敗
  • ConfigMgr 2007 狀態:除非目前的備份工作完成，否則站台備份無法開始進行備份程序
  • ConfigMgr 2007 狀態:站台備份發現 SQL 備份路徑是空的或無效
  • ConfigMgr 2007 服務已停止執行:SMS_SITE_BACKUP
  • ConfigMgr 2007 服務已開始執行SMS_SITE_BACKUP
  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 意外終止
  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 啟動時無反應
  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 無法啟動
  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 無法登入
  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 依存於另一項服務，但該服務無法啟動或不存在

  • ConfigMgr 2007 服務執行中:SMS_SITE_VSS_WRITER
  • ConfigMgr 2007 服務失敗:SMS_SITE_VSS_WRITER 意外終止
  • ConfigMgr 2007 服務失敗:SMS_SITE_VSS_WRITER 啟動時無反應
  • ConfigMgr 2007 服務失敗:SMS_SITE_VSS_WRITER 無法啟動
  • ConfigMgr 2007 服務失敗:SMS_SITE_VSS_WRITER 無法登入
  • ConfigMgr 2007 服務失敗:SMS_SITE_VSS_WRITER 依存於另一項服務，但該服務無法啟動或不存在

所有警示產品知識內容

系統管理員可以參考所有警示的產品知識內容，這些產品知識內容可以特別協助他們辨識問題並解決問題。如果要存取產品知識內容，在任何規則名稱上按滑鼠右鍵，按一下 [Properties]，然後按一下 [Product Knowledge] 索引標籤。

所有 Configuration Manager 伺服器和用戶端角色電腦群組

電腦群組會對應到特定 Configuration Manager 伺服器與用戶端角色。規則與監視目標則是以類別為基礎，其同樣對應到 Configuration Manager 伺服器與用戶端角色。這樣可以為管理組件規則的目標，提供系統管理員適當的控制層級。

擴充監視

Configuration Manager 管理組件中提供的規則涵蓋以下依存技術的基本服務、效能計量以及效能閾值監視：SQL Server、IIS、BITS、Windows 作業系統、WMI、WSUS、Windows 部署服務以及 Trivial FTP。根據預設，會停用部分支援。您可以在 Configuration Manager 管理組件中啟用和使用有限的支援，但建議您也匯入和使用上述特定產品的管理組件。

  • 使用 SQL Server 管理組件擴充監視 Configuration Manager 站台資料庫伺服器、具有複寫站台資料庫的管理點，以及需依賴 SQL Server 的軟體更新點。
  • 使用 IIS 管理組件監視報告點、管理點、伺服器定位器點、狀態移轉點，以及後援狀態點上的 IIS。IIS 管理組件也能監視啟用 BITS 的發佈點。
  • 使用 Microsoft Windows 作業系統管理組件監視基本的 Windows 元件，例如 CPU、磁碟以及記憶體統計資料。

還有 Configuration Manager 2007 管理組件所未提供規則的其他管理組件，能加強監視 Configuration Manager 基礎結構。

  • 如果您基於延展性考量，而要使用網路負載平衡支援 Configuration Manager 階層中的多種管理點，請使用 Windows 網路負載平衡管理組件。
  • 使用 Windows Active Directory® 管理組件監視 Active Directory 基礎結構的健康狀態。

如果您在環境中部署多種管理組件，您可能會因為同時存在於兩套管理組件中的規則，而收到多餘的警示。如果您停用多餘的監視規則，可能會影響到所部署管理組件的狀態檢視精確度。您應該謹慎考慮這兩項情況間的交換條件：接收重複警示，以及讓每套部署的管理組件的狀態監視生效。請視您已部署的額外管理組件而定，檢閱這些重複的規則，以識別任何可能要在您的環境中啟用的規則。安裝這些管理組件後，請確認您已視需要自訂這些管理組件、妥善設定，並已啟用適用的規則。

軟體發佈程式執行狀態

Configuration Manager 用戶端可以透過管理組件報告程式失敗。

系統管理員可以在 [Program Properties] 對話方塊中，選取 [MOM Maintenance Mode] 索引標籤上的 [Generate Operations Manager alert if this program fails] 核取方塊。

程序

如果 Configuration Manager 2007 程式無法執行，請依下列步驟啟用 Operations Manager 2007 警示：

為 Configuration Manager 程式啟用 Operations Manager 2007 警示

  1. 在 Configuration Manager 主控台中，瀏覽到 [Systems Center Configuration Manager] / [Site Database - <站台伺服器名稱>] / [Computer Management] / [Software Distribution] / [Packages / <封裝名稱> ] / [Programs]。

  2. 在詳細資料窗格中，在程式上按一下滑鼠右鍵，然後按一下 [Properties]。

  3. 按一下 [MOM Maintenance Mode] 索引標籤。

  4. 選取 [Generate Operations Manager alert if this program fails to run] 核取方塊。按一下 [確定]。

ConfigMgr 工作監視

像是集合評估、狀態訊息摘要以及站台維護等針對 ConfigMgr 站台資料庫執行的工作，其完成狀態與執行時間全都受到監視。如果工作失敗或工作執行的時間超出預期的時間上限，便會產生警示。

元件記錄檔監視

下列規則是以監視 sender.log、distmgr.log 以及 policypv.log 檔案為基礎：

  • SMSv4 元件：傳送者無法透過 LAN (標準安全性) 連線至遠端站台。
  • SMSv4 元件：傳送者無法透過 RAS 連線連接至遠端站台。
  • ConfigMgr 2007 元件:傳送者無法透過 LAN (進階安全性) 連線至遠端站台。
  • ConfigMgr 2007 元件:Distribution Manager 無法處理封裝。
  • ConfigMgr 2007 元件:Distribution Manager 無法插入 SMS Package，因為 CI_Contents 表格中沒有 SDM Type Content。
  • ConfigMgr 2007 元件:原則提供者無法從 SMS 站台資料庫取得新的軟體更新原則。
  • ConfigMgr 2007 元件:原則提供者無法建立新的軟體更新原則。
  • ConfigMgr 2007 元件:原則提供者無法從 SMS 站台資料庫取得新的更新狀態原則。
  • ConfigMgr 2007 元件:原則提供者無法建立新的更新狀態原則。
  • ConfigMgr 2007 元件:原則提供者無法通知 Hierarchy Manager 原則已發生變更。

Configuration Manager 2007 收件匣監視

Configuration Manager 2007 透過讀取和寫入其收件匣中的檔案，進行其大部分主要的伺服器端活動。當 Configuration Manager 2007 收件匣異常地過滿時，很有可能表示 Configuration Manager 2007 處理進度落後。可能造成這種情形的原因有很多，包括但不限於檔案損壞、處理序停止、磁碟空間不足或軟體發佈活動等級異常。這類問題相當罕見，但對於擁有大量站台的客戶而言是相當嚴重的問題。

收件匣監視 (以 SMS Executive 服務執行緒的方式執行) 會監視服務元件所佇列的項目數，而不是磁碟上實際等待處理的項目數。

所有規則都位於中央、主要和次要站台伺服器上，以這些規則為目標的 [ConfigMgr 2007 Site Servers – Common] 處理安裝類別中。

排程和選用設定

為將收件匣監視的效能影響降至最低，多個適當的規則會每日同步執行一次。規則會從上午 01:00 開始，以 15 分鐘的間隔互相錯開，使得一次僅執行一項規則。例如，第一項規則會在上午 01:00 計算存在於第一個收件匣中的檔案。下一項規則會在上午 01:15 計算存在於第二個收件匣中的檔案，依此類推，直到所有收件匣都計算完畢為止。

您可以依照您在 Operations Manager 2007 中進行排程以執行規則指令碼的一般步驟來修改上述排程。啟用此功能並不需要初始設定。以下是您可以執行的選用設定變更：

  • 為每個收件匣變更預設閾值。
  • 為個別收件匣規則變更排程。

依照在任何管理組件中設定閾值事件規則的一般步驟，便可以變更這些選用設定。

閾值警示與值

每當監視規則處理後達到特定收件匣規則的設定閾值時，會產生警示。

編輯效能閾值

  1. 在 [Operations Manager 2007] 系統管理員主控台中，按一下 [撰寫中]。

  2. 在 [撰寫中] 窗格中，瀏覽到 [撰寫中] > [管理組件物件] > [監視]。

  3. 在 [監視] 窗格中，尋找 [ConfigMgr 伺服器]。

  4. 瀏覽到 [ConfigMgr 伺服器] > [實體健全狀況] > [可用性]，然後展開所要編輯的下列其中一個伺服器角色：

    • DB - 資料庫伺服器
    • DP - 發佈點
    • FSP - 後援狀態點
    • MP - 管理點伺服器
    • PSP - PXE 服務點
    • SS - 站台伺服器
    • Provider - 提供者
    • RP - 報告點
    • SHV - 系統健康狀態驗證
    • SLP - 伺服器定位器點
    • SMP - 狀態移轉點
    • SUP - 軟體更新點

  5. 在您想要編輯其效能的監視上按一下滑鼠右鍵，瀏覽到 [覆寫] > [覆寫監視]，然後按一下會受到覆寫作業影響的物件類別。

  6. 根據您的環境，選取核取方塊以設定監視的 [覆寫內容]。按一下 [確定]。

如需收件匣資料夾與其如何用於 Configuration Manager 的相關資訊，請參閱主題為＜收件匣資料夾描述以及如何在 Configuration Manager 中使用收件匣＞的網頁 (http://go.microsoft.com/fwlink/?LinkId=99539) (英文)。

請參閱

其它資源

部署 Configuration Manager 2007 管理組件
Configuration Manager 2007 管理組件的參考資料


執行 Configuration Manager 2007 管理組件的操作工作

建議您立即檢閱並解決所有警示，以確認重要檢視或具備潛在嚴重性質的警示。此外，您應該定期執行其他工作 (視環境而定)。許多重要問題並不會引發警示，但您仍然必須定期注意這些問題。System Center Configuration Manager 2007 管理組件具備檢視和報告，能顯示隨時間發展的資料，並展示問題的圖樣。檢閱這些檢視和報告，事先解決問題，就不會引發警示。

您應該依照此節指定的方式，執行每日、每週及每月工作，但請調整這些工作的頻率，以符合特定環境的需求。

如需維護 Configuration Manager 2007 的詳細資訊，請參閱「維護 Configuration Manager 2007」(http://go.microsoft.com/fwlink/?LinkId=102324) (可能為英文網頁)。如需有關站台維護的詳細資訊，請參閱「站台維護概觀」(http://go.microsoft.com/fwlink/?LinkId=102325) (可能為英文網頁)。

在此章節中

Configuration Manager 2007 管理組件的每日工作

Configuration Manager 2007 管理組件的每週工作

Configuration Manager 2007 管理組件的每月工作

請參閱

概念

Configuration Manager 2007 的管理組件監視案例
Configuration Manager 2007 與 Operations Manager 2007 的整合

其它資源

Configuration Manager 2007 管理組件概觀
部署 Configuration Manager 2007 管理組件
執行 Configuration Manager 2007 管理組件的操作工作
Configuration Manager 2007 管理組件的參考資料
疑難排解 Configuration Manager 2007 管理組件問題


Configuration Manager 2007 管理組件的每日工作

建議每天執行下列工作：

  • 檢閱電腦群組成員資格。
  • 確認所有的 Operations Manager 2007 代理程式正與 Operations Manager 2007 Server 通訊。
  • 檢閱「站台階層狀況檢視」。
  • 檢閱「站台狀態檢視」。
  • 檢閱「站台階層圖表」。
  • 檢閱所有未解決的警示。在任何檢視或圖表中使用健全狀況總管向下鑽研。
  • 檢閱效能待處理項目。
  • 檢閱效能處理速度。
  • 檢閱 Operations Manager 2007 代理程式和伺服器效能。
  • 若每日執行 ConfigMgr 站台備份，請檢閱備份狀態與備份檔案。
  • 檢閱事件 (選擇性)。

檢閱所有未解決的警示

Configuration Manager 2007 管理組件中的許多警示都會以下列警示說明格式顯示：

$Computer$ <Rule Name>

$Description$

Event details

檢閱 Operations Manager 2007 的所有警示，以確保即時處理這些警示。您可以使用下列任一方法，檢閱未解決的警示：

  • 在操作主控台中，按一下 [監視] 按鈕，展開 [Microsoft System Center Configuration Manager 2007]，然後按一下 [警示]。
  • 在操作主控台中，按一下 [監視] 按鈕，展開 [Microsoft System Center Configuration Manager 2007]，然後按一下 [一般]。選取 [過去 72 小時內的新警示]。
  • 按一下 [撰寫模式] 並選取 [群組]，即可依電腦或電腦群組檢視警示。在您要檢查的 Configuration Manager 2007 電腦群組上按一下滑鼠右鍵，選取 [狀態檢視]，然後選取 [未解決的警示]。
  • 您可以透過 [電腦狀態] 檢視來檢視警示。此檢視會顯示電腦與探索之類別的清單。在任何電腦上按一下滑鼠右鍵並選取 [未解決的警示] 檢視，以取得依嚴重性排定優先順序的最新警示清單。
  • 您可以透過 [站台狀態] 檢視來檢視警示。[站台狀態] 檢視會檢視站台與探索之類別的清單。在任何站台上按一下滑鼠右鍵並選取 [未解決的警示] 檢視，以取得依嚴重性排定優先順序的最新警示清單。
  • 您可以透過 [站台階層狀態] 檢視來檢視警示。[站台階層狀態] 檢視會顯示站台階層與探索之類別的清單。在階層執行個體上按一下滑鼠右鍵並選取 [未解決的警示] 檢視，以取得依嚴重性排定優先順序的最新警示清單。
  • 您可以透過 [站台階層圖表] 檢視來檢視警示。[站台階層圖表] 檢視會顯示以圖形化方式呈現的 Configuration Manager 2007 站台階層。在圖表中顯示的任何物件上按一下滑鼠右鍵並選取 [未解決的警示] 檢視，以取得依嚴重性排定優先順序的最新警示清單。

建議您以下列順序檢閱所有新警示：

  1. Configuration Manager 2007 安裝失敗警示
  2. Configuration Manager 2007 核心服務警示
  3. Configuration Manager 2007 依存服務警示
  4. Configuration Manager 2007 指令碼錯誤警示
  5. Configuration Manager 2007 伺服器角色警示
  6. Configuration Manager 2007 元件警示
  7. 根據 Configuration Manager 2007 站台系統狀態摘要器作業產生之警示
  8. 根據 Configuration Manager 2007 狀態訊息產生之警示
  9. Configuration Manager 2007 效能閾值警示
  10. Configuration Manager 2007 收件匣監視警示
  11. Configuration Manager 2007 寄件匣監視警示
  12. Configuration Manager 2007 工作監視警示
  13. Configuration Manager 2007 站台備份失敗警示
  14. Configuration Manager 2007 程式失敗警示

檢閱電腦群組成員資格

您可以使用 Operations Manager 2007 確認電腦群組成員資格。

在操作主控台中，按一下 [撰寫中] 按鈕，按一下 [群組]，然後在適當的 Microsoft Configuration Manager 2007 電腦群組上按一下滑鼠右鍵。確認每個顯示的電腦群組包含正確的電腦。

確認代理程式正與 Operations Manager 2007 Server 通訊

代理程式與監視基礎結構間的通訊失敗會讓您無法收到警示。確認代理程式與執行 Operations Manager 2007 的伺服器正在進行通訊，方式是確認 [電腦狀態] 檢視中 Configuration Manager 伺服器的健全狀況狀態未顯示為灰色。

檢閱效能待處理項目和效能處理速度

效能待處理項目和效能處理速度對於偵測每日趨勢，以及瞭解 Configuration Manager 階層中的狀況而言非常有用。效能待處理項目和效能處理速度可於 Operations Manager 2007 中檢視。

檢閱效能待處理項目

若要檢閱效能待處理項目，請執行下列步驟：

檢閱效能待處理項目

  1. 在操作主控台中，按一下 [監視] 按鈕，然後展開 [Microsoft System Center Configuration Manager 2007]。

展開 [效能]，然後展開 [待處理項目]。接著，按一下適當的伺服器角色子資料夾與檢視。按一下 [顯示] 按鈕，以指定要在計數器圖表中顯示的電腦。

檢閱效能處理速度

若要檢閱效能處理速度，請執行下列步驟：

檢閱效能處理速度

  1. 在操作主控台中，按一下 [監視] 按鈕，然後展開 [Microsoft System Center Configuration Manager 2007]。

  2. 展開 [效能]，然後展開 [處理速度]。接著，按一下適當的伺服器角色子資料夾與檢視。按一下 [顯示] 核取方塊，以指定要在計數器圖表中顯示的電腦。

檢閱效能條件

若要檢閱效能條件，請執行下列步驟：

檢閱效能條件

  1. 在操作主控台中，按一下 [監視] 按鈕，然後展開 [Microsoft System Center Configuration Manager 2007]。

  2. 展開 [效能]，然後展開 [條件]。接著，按一下適當的伺服器角色子資料夾與檢視。選取 [顯示] 核取方塊，以指定要在計數器圖表中顯示的電腦。

Configuration Manager 2007 備份監視

請根據您企業環境的需求，啟用 Configuration Manager 2007 站台備份維護工作並排程備份。Configuration Manager 站台備份處理程序支援 VSS，但不支援在下列處理程序期間的執行階段備份：

  • 複製部分 Configuration Manager 安裝資料夾到備份匯出路徑
  • 備份多種 Configuration Manager 登錄值
  • 在執行 Microsoft SQL Server™ 的伺服器上備份 Configuration Manager 站台資料庫

備份完成時，Configuration Manager 站台備份服務會重新啟動 SMS 服務。備份程序期間，這些服務停止或啟動都是正常的，不代表發生重大錯誤。進行 Configuration Manager 站台備份期間，正常情況下會從這些停止之服務產生的警示都會被抑制，因為備份將會暫停 MOM 代理程式 (就本質上而言是將它切換到代理程式維護模式)。若要將站台的啟動與完成建立關聯，您應該啟用下列規則，當 SMS 站台備份服務啟動或停止時這些規則會產生資訊警示：

  • ConfigMgr 2007 服務已停止執行:SMS_SITE_BACKUP
  • ConfigMgr 2007 服務已開始執行SMS_SITE_BACKUP

當 Configuration Manager 站台備份服務無法啟動或意外停止時，會產生下列警示：

  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 意外終止
  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 啟動時無反應
  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 無法啟動
  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 無法登入
  • ConfigMgr 2007 服務失敗:SMS_SITE_BACKUP 依存於另一項服務，但該服務無法啟動或不存在

如果您看到指出服務意外終止的警示，請確認所有停止的服務已重新啟動。Configuration Manager 站台備份服務可能在重新啟動這些服務前已經終止。

系統會產生下列狀態訊息警示，顯示備份程序成功或失敗：

  • ConfigMgr 2007 狀態:站台備份已成功完成
  • ConfigMgr 2007 狀態:站台備份失敗
  • ConfigMgr 2007 狀態:除非目前的備份工作完成，否則站台備份無法開始進行備份程序
  • ConfigMgr 2007 狀態:站台備份發現 SQL 備份路徑是空的或無效

產生失敗警示的原因可能包括：存取權問題、磁碟空間不足、無法啟動或停止特定服務，或 SQL Server 運作失敗。

檢閱事件

建議您定期檢閱事件，因為事件會指出不嚴重的失敗，並能讓您瞭解 Operations Manager 2007 代理程式的運作情況。

檢閱事件

若要檢閱事件，請執行下列步驟：

檢閱事件

  1. 在操作主控台中，按一下 [監視] 按鈕。

  2. 展開 [Microsoft System Center Configuration Manager 2007]，然後按一下 [事件]。

請參閱

概念

Configuration Manager 2007 與 Operations Manager 2007 的整合
Configuration Manager 2007 的管理組件監視案例

其它資源

Configuration Manager 2007 管理組件的參考資料
疑難排解 Configuration Manager 2007 管理組件問題


Configuration Manager 2007 管理組件的每週工作

除了每天執行的工作外，請每週執行下列工作：

  • 檢閱報告。若要查看 Configuration Manager 2007 管理組件中包含的報告清單，請參閱本指南的 Configuration Manager 2007 管理組件的報告一節。
  • 檢閱上一週的警示、事件、伺服器可用性、設定變更及效能，了解可能的問題和趨勢。
  • 如果需要，請調整 Operations Manager 2007 的組態設定，例如 Operations Manager 2007 代理程式活動訊號間隔時間、警示設定，以及資料庫整理參數。
  • 檢閱 Configuration Manager 2007 站台的備份歷程。
  • 檢閱 Configuration Manager 2007 之 Operations Manager 2007 設定群組的備份歷程。
  • 檢閱 SQL Server 資料庫和記錄檔。
  • 執行 Configuration Manager 2007 可用性報告，以取得 Configuration Manager 2007 伺服器及其角色的可用性。
  • 使用 Configuration Manager 2007 站台階層圖表來檢查 Configuration Manager 2007 階層。

請參閱

概念

Configuration Manager 2007 管理組件的每日工作
Configuration Manager 2007 管理組件的每月工作

其它資源

疑難排解 Configuration Manager 2007 管理組件問題
Configuration Manager 2007 管理組件的參考資料


Configuration Manager 2007 管理組件的每月工作

除了您每日及每週執行的工作外，請每個月檢視下列類別中的資料：

  • 檢閱通知訂閱與收件者。確認已為每項訂閱選取適當的群組與類別。

最常見的警示和事件

  • 最常見的警示
  • 最常見的事件
  • 在電腦與類別方面最常見的警示與事件
  • 在 Configuration Manager 2007 元件方面最常見的警示與事件
  • 在 Configuration Manager 2007 伺服器角色方面最常見的警示與事件

發展行動計畫來降低這些數目。

Configuration Manager 2007 待處理項目監視

查看多種站台系統上與待處理項目趨勢相關的效能原始報告。

Configuration Manager 2007 待處理項目趨勢

檢閱原始效能以及與速度相關的報告，確認在 Configuration Manager 2007 站台系統上，會影響服務等級協定 (SLA) 的待處理項目的數量或無法接受的待處理項目等級沒有長期增加的趨勢。請檢閱下列項目：

  • 探索資料記錄
  • 硬體清查
  • 軟體清查
  • 軟體計量
  • 狀態訊息
  • 狀況訊息

一般系統效能

檢閱伺服器系統資源效能報告，檢查下列項目的系統效能：

  • 磁碟使用狀況
  • 記憶體使用狀況
  • 處理器使用狀況

伺服器角色效能

檢閱下列每個角色的原始與速度效能報告：

  • 裝置管理點
  • 管理點
  • 站台伺服器

Configuration Manager 2007 可用性

執行 Configuration Manager 2007 可用性報告，以檢閱 Configuration Manager 2007 伺服器與 Configuration Manager 2007 伺服器角色的可用性。

Configuration Manager 2007 站台階層監視

檢閱 Configuration Manager 站台階層中的代理程式安裝，以及判斷監視的涵蓋範圍對於部署的伺服器是否足夠。可能已部署的新 Configuration Manager 伺服器，但其上尚未安裝 MOM 代理程式。

請參閱

概念

Configuration Manager 2007 管理組件的每日工作
Configuration Manager 2007 管理組件的每週工作
Configuration Manager 2007 與 Operations Manager 2007 的整合

其它資源

執行 Configuration Manager 2007 管理組件的操作工作
Configuration Manager 2007 管理組件的參考資料
疑難排解 Configuration Manager 2007 管理組件問題


疑難排解 Configuration Manager 2007 管理組件問題

有多個動作可讓您進行產品問題疑難排解：

  • 確認已正確安裝 Operations Manager 2007。
  • 確認 Operations Manager 2007 組態已正確設定。
  • 確認已利用 Operations Management 登錄機碼正確設定所有 System Center Configuration Manager 2007 系統。
  • 確認所有受管理的 Configuration Manager 2007 提供者與 Configuration Manager 2007 站台伺服器電腦均已安裝 Operations Manager 2007 代理程式，而且可為其他電腦進行 Proxy 處理。
  • 確認您已成功匯入管理組件。
  • 確認已經啟用所有相關實體，例如規則與監視。
  • 確認電腦群組中都已填入正確的電腦。您可以在主控台中使用 [撰寫中] 模式的 [群組] 節點，來執行這項檢查。
  • 確認所有代理程式均狀況良好。
  • 確認活動訊號間隔時間已正確設定且規則已傳播到 Operations Manager 2007 代理程式電腦。
  • 確認依存服務 (包括 Windows Management Instrumentation (WMI)、World Wide Web Publishing 服務、網際網路資訊服務 (IIS) 管理服務、背景智慧型傳送服務 (BITS)、Windows Server Update Services (WSUS)、Windows 部署服務伺服器 (WDS)、Trivial FTP 精靈 (TFTPD) 以及 MSSQLServer) 已於 Configuration Manager 2007 站台系統上安裝並正常運作。
  • 確認已正確安裝所有效能計數器。
  • 確認指令碼有足夠的權限可以存取所需的資源 (如果動作帳戶不是 Local System 帳戶)。

在此章節中

Configuration Manager 2007 管理組件的已知問題

請參閱

概念

Configuration Manager 2007 的管理組件監視案例

其它資源

Configuration Manager 2007 管理組件概觀
部署 Configuration Manager 2007 管理組件
執行 Configuration Manager 2007 管理組件的操作工作
Configuration Manager 2007 管理組件的參考資料


Configuration Manager 2007 管理組件的已知問題

下列是 Operations Manager 2007 的 Configuration Manager 2007 管理組件的已知問題。

Configuration Manager 2007 可能干擾會停止 WMI 服務之非 Microsoft 軟體的安裝程序

WMI 監視

若 SMS 系統管理員主控台安裝在相同的電腦上，則 Configuration Manager 2007 管理組件無法偵測 SMS 次要站台

系統重新啟動提供有限的警示

Configuration Manager 2007 中的 Monitor SMS Status Messages 指令碼

Configuration Manager 2007 中的 Monitor Site Summarizer 指令碼自預設站台系統狀態摘要器間隔偏移

預設停用 BITS 監視

應用程式提供者路徑依預設會設定為 SMS_INSTALL_DIR_PATH% \ Logs，此項設定不一定在每個 Configuration Manager 站台伺服器上都有效

監視傳送者連接的狀態訊息規則具有傳送者運作相依性

站台拓撲檢視中的指令碼錯誤顯示安裝路徑而非電腦名稱

所有 Configuration Manager 伺服器上都必須安裝代理程式才能支援站台階層圖表

SMS 2003 工作出現在 Configuration Manager 2007 狀況檢視中

Configuration Manager 可能干擾會停止 WMI 服務之非 Microsoft 軟體的安裝程序

Configuration Manager 2007 管理組件可能干擾會存取 Windows Management Instrumentation (WMI) 服務之非 Microsoft 軟體的安裝程序。大多數管理組件的指令碼使用 WMI 存取登錄，並會重新啟動 WMI 服務。如果 WMI 服務已啟用並可加以啟動，則元件物件模型 (COM) 就可以順利重新啟動 WMI。

如果非 Microsoft 軟體停止，但於安裝或升級時未停用 WMI，則自動重新啟動 WMI 指令碼可能會讓非 Microsoft 軟體無法成功安裝。如果安裝程式未先停用 WMI 服務，這會造成 WMI 或 WMI 提供者的升級問題。此問題會影響所有 WMI 用戶端。

WMI 監視

  • 下列規則是以 Windows NT® 系統事件日誌的事件為基礎，這些事件是由服務控制管理員的意外服務失敗所引起。這些規則沒有已知的作業系統限制。
  • Configuration Manager 2007 依存服務失敗：Windows Management Instrumentation 意外終止。
  • Configuration Manager 2007 依存服務失敗：Windows Management Instrumentation 啟動時無反應。
  • Configuration Manager 2007 依存服務失敗：Windows Management Instrumentation 無法啟動。
  • Configuration Manager 2007 依存服務失敗：Windows Management Instrumentation 無法登入。
  • Configuration Manager 2007 依存服務失敗：Windows Management Instrumentation 依存於另一項服務，但該服務無法啟動或不存在。

若 ConfigMgr 2007 系統管理員主控台安裝在相同的電腦上，則 Configuration Manager 2007 管理組件無法偵測次要站台

將 Configuration Manager 2007 系統管理員主控台安裝在同樣為 Configuration Manager 2007 次要站台伺服器的電腦上會導致 Configuration Manager 2007 管理組件無法將伺服器識別為 Configuration Manager 2007 次要站台伺服器。

此問題的解決方法：將 Configuration Manager 2007 系統管理員主控台安裝在 Configuration Manager 2007 次要站台伺服器上時，您需要將登錄值 HKLM\SOFTWARE\Microsoft\SMS\Setup\Type 從 4 變更為 2。

系統重新啟動提供有限的警示

在系統重新啟動時，您可能只收到一些服務停止警示。沒有事件或警示指出系統已重新啟動。偵測預期或非預期的系統關機的最佳解決方案是安裝 Microsoft Windows Servers Base Operating System 管理組件，其中包含會警示系統重新啟動的規則。其他判定系統是否重新啟動的方式包括：檢查 Configuration Manager 2007 記錄、Operations Manager 2007 NT 事件日誌、Windows NT 事件日誌，以及 Operations Manager 2007 代理程式通訊的事件。

Configuration Manager 2007 中的 Monitor SMS Status Messages 指令碼

當 Configuration Manager 2007 狀態訊息表超過 4,294,967,296 個訊息時，記錄識別碼會回歸至零重新開始。Configuration Manager 2007 中的 Monitor SMS Status Messages 指令碼沒有機制可以偵測記錄識別碼何時回歸至零重新開始。指令碼目前只會偵測最後處理的狀態訊息的記錄識別碼。如果記錄識別碼重新啟動，管理組件就無法偵測到任何新的狀態訊息。

在站台伺服器上，請注意 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER 登錄機碼中的 Next Status Message Record ID 登錄值。這是位於 SQL StatusMessages 表中的下一個記錄識別碼。如果這個值比 LastRecordID 值小，表示 StatusMessages 表已經歸零且重新啟動。除非 Next Status Message Record ID 登錄值大於 Varset 檔案中的 LastRecordID 值，否則指令碼無法再次處理訊息。

請務必定期監視站台伺服器上的 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER 登錄機碼，以取得下個狀態訊息的記錄識別碼。位於 SMS 較低階層的小型組織或小型站台，應每隔二至三個月檢查一次此登錄機碼。內含數個子站台的大型組織或站台，應每個月檢查此登錄機碼。如果值接近 4,294,967,296，請增加監視頻率。記錄識別碼歸零後，您必須在執行站台伺服器的電腦上解除鎖定狀態訊息監視。

自動化登錄機碼監視的方式之一，就是為接近此閾值的電腦建立指令碼或探索規則。

若要在您的設定群組中尋找所有 Configuration Manager 2007 站台資料庫，請執行下列程序。請注意，您現在可以在站台伺服器上的 ConfigMgr 中找到站台資料庫伺服器角色，這是為了支援叢集 SQL Server。

程序

在您的設定群組中尋找所有 Configuration Manager 2007 站台資料庫，以及解除鎖定狀態訊息監視

  1. 在操作主控台中，按一下 [撰寫中] 按鈕，然後選取 [群組]。

  2. 在結果窗格中，搜尋包含「Microsoft ConfigMgr 2007 站台資料庫伺服器電腦群組」的群組名稱。

  3. 在您要尋找其成員的群組名稱上按一下滑鼠右鍵，然後選取 [檢視群組成員]。

  4. 在持有 Configuration Manager 2007 站台資料庫角色的電腦上，在用以執行指令碼之使用者內容的 TMP 環境變數 (若使用 Local System，則為 Windows 的 [Temp] 資料夾) 所指定的目錄中，開啟下列文字檔：ConfigMgr 2007 Monitor SMS Status Messages.SCOM2007.VarSet 檔案。LastRecordID_[SMSDatabaseName] 項目為記錄識別碼值，該值表示指令碼處理的 SQL StatusMessages 表中的最後狀態訊息。

  5. 將 LastRecordID_[SMSDatabaseName] 值變更為等於 Next Status Message record ID 登錄值減一。如果結果為 4,294,967,296，請將值設定為零並儲存檔案。

Configuration Manager 2007 中的 Monitor Site Summarizer 指令碼自預設站台系統狀態摘要器間隔偏移

Configuration Manager 2007 之 Monitor Site Summarizer 指令碼執行的間隔自輪詢間隔為一小時的站台系統狀態摘要器偏移 10 分鐘。即使 Configuration Manager 系統管理員主控台允許設定站台系統狀態摘要器排程，也不會變更此輪詢間隔，僅會變更其他維護工作的間隔。Configuration Manager 中的 Monitor Site System Summarizer 指令碼會「每隔 60 分鐘在 00:10 進行同步處理」。10 分鐘的偏移期間能提供站台系統狀態摘要器完成其循環所需的時段。如果這段時間不夠，應延長此時段，否則指令碼會在站台系統摘要器完成其循環前結束。這會導致報告舊的站台系統狀態。

預設停用 BITS 監視

因為背景智慧型傳送服務 (BITS) 已由於 Configuration Manager 2007 Client 的要求啟動，下列規則預設會在 Configuration Manager 管理組件中停用：

  • 執行的 ConfigMgr 2007 依存服務:背景智慧型傳送服務

如果您將服務設為自動啟動，應啟用此規則。

下列規則依預設會啟用，以監視 BITS 服務問題並報告 SMS Agent Host 無法於需要時啟動 BITS 服務的情形：

  • ConfigMgr 2007 服務失敗:背景智慧型傳送服務意外終止。
  • ConfigMgr 2007 服務失敗:背景智慧型傳送服務啟動時無反應。
  • ConfigMgr 2007 服務失敗:背景智慧型傳送服務無法啟動。
  • ConfigMgr 2007 服務失敗:背景智慧型傳送服務無法登入。
  • ConfigMgr 2007 服務失敗:背景智慧型傳送服務依存於另一項服務，但該服務無法啟動或不存在。

應用程式提供者路徑預設會設定為 SMS_INSTALL_DIR_PATH% \ Logs，此項設定不一定在每個 SMS 站台伺服器上都有效

下列元件規則使用應用程式記錄檔：

  • ConfigMgr 2007 元件:傳送者無法透過 LAN (標準安全性) 連線至遠端站台。
  • ConfigMgr 2007 元件:傳送者無法透過 RAS 連線連接至遠端站台。
  • ConfigMgr 2007 元件:傳送者無法透過 LAN (進階安全性) 連線至遠端站台。
  • ConfigMgr 2007 元件:Distribution Manager 無法處理封裝。
  • ConfigMgr 2007 元件:Distribution Manager 無法插入 SMS Package，因為 CI_Contents 表格中沒有 SDM Type Content。
  • ConfigMgr 2007 元件:原則提供者無法從 SMS 站台資料庫取得新的軟體更新原則。
  • ConfigMgr 2007 元件:原則提供者無法建立新的軟體更新原則。
  • ConfigMgr 2007 元件:原則提供者無法從 SMS 站台資料庫取得新的更新狀態原則。
  • ConfigMgr 2007 元件:原則提供者無法建立新的更新狀態原則。
  • ConfigMgr 2007 元件:原則提供者無法通知 Hierarchy Manager 原則已發生變更

若要讓這些原則能運作，您必須在站台伺服器上建立 %SMS_INSTALL_DIR_PATH% 環境變數，並將該變數的值指定為站台安裝的安裝路徑。環境變數路徑的結尾不能是反斜線。每部具有傳送者的 Configuration Manager 2007 伺服器都必須是受管理的電腦。

所有規則 (「ConfigMgr 2007 元件:Distribution Manager 無法處理封裝」除外) 預設都會啟用。

監視傳送者連接的狀態訊息規則具有傳送者運作相依性

如果傳送者無法連接到其父站台，狀態訊息不會於 Configuration Manager 階層上移，且管理組件不會產生這些狀態訊息的警示。這在沒有執行 ConfigMgr 2007 Monitor Status Message 指令碼的次要站台的情況中特別明顯。下列監視傳送者連接的狀態訊息規則具有傳送者運作相依性且依預設會停用：

  • ConfigMgr 2007 狀態:傳送者無法透過 LAN (標準安全性) 連線至遠端站台。
  • ConfigMgr 2007 狀態:傳送者無法透過 RAS 連線連接至遠端站台。
  • ConfigMgr 2007 狀態:傳送者無法透過 LAN (進階安全性) 連線至遠端站台。
附註
所有這些規則依預設會停用。為讓這些規則正常運作，每部 SMS 站台資料庫伺服器 (或至少中央站台) 都必須是受管理的電腦。

平行監視方法是以 Configuration Manager 2007 傳送者記錄為基礎提供。這些規則依預設會啟用。如果您停用這些規則，請考慮啟用上述相輔的狀態訊息規則。請不要同時啟用兩組規則，因為這樣會產生重複警示。合併這些事件或警示規則無法同時處理啟用的狀態訊息和元件規則。

  • ConfigMgr 2007 元件:傳送者無法透過 LAN (標準安全性) 連線至遠端站台。
  • ConfigMgr 2007 元件:傳送者無法透過 RAS 連線連接至遠端站台。
  • ConfigMgr 2007 元件:傳送者無法透過 LAN (進階安全性) 連線至遠端站台。

若要讓這些原則能運作，您必須在站台伺服器上建立 %SMS_INSTALL_DIR_PATH% 環境變數，並將該變數的值指定為站台安裝的安裝路徑。環境變數路徑的結尾不能是反斜線。此外，每部具有傳送者的 Configuration Manager 伺服器都必須是受管理的電腦。如需詳細資訊，請參閱應用程式提供者路徑依預設會設定為 SMS_INSTALL_DIR_PATH% \ Logs，此項設定不一定在每個 Configuration Manager 站台伺服器上都有效。

站台階層探索檢視中的指令碼錯誤顯示安裝路徑而非電腦名稱

從 ConfigMgr 2007 Site Hierarchy Discovery 指令碼與原生建立的規則檢視指令碼錯誤時，系統會將產生該錯誤之電腦的安裝類別顯示為 [來源]。產生該錯誤之電腦的電腦名稱會顯示為指令碼錯誤之 [警示描述] 或 [路徑] 的一部分。

所有 Configuration Manager 伺服器上都必須安裝代理程式才能支援站台階層圖表

若要讓「站台階層圖表」能運作，您必須在站台中所有 Configuration Manager 伺服器 (包括裝載站台資料庫的任何遠端 SQL 伺服器) 的本機安裝代理程式。對於所有要監視的站台 (包括中央站台、主要站台與次要站台) 而言此動作是必要的。

SMS 2003 工作出現在 Configuration Manager 2007 狀況檢視中

同時安裝 System Management Server (SMS) 2003 與 Configuration Manager 2007 管理組件時，SMS 2003 工作會出現在 Configuration Manager 2007 狀態檢視中，因為 SMS 2003 工作是以 Windows 電腦類別為目標，而非以 SMS 伺服器類別為目標。

請參閱

概念

支援的 Configuration Manager 2007 管理組件設定

其它資源

疑難排解 Configuration Manager 2007 管理組件問題
Configuration Manager 2007 管理組件概觀
Configuration Manager 2007 管理組件的參考資料


Configuration Manager 2007 管理組件的參考資料

下列參考資料提供 Operations Manager 2007 與 Configuration Manager 2007 的相關指導。

在此章節中

Configuration Manager 2007 管理組件的其他資源

Configuration Manager 2007 管理組件的站台與元件

Configuration Manager 2007 管理組件的電腦群組

Configuration Manager 2007 管理組件的安裝類別

Configuration Manager 2007 管理組件的指令碼

Configuration Manager 2007 管理組件的檢視

Configuration Manager 2007 管理組件的圖表

Configuration Manager 2007 管理組件的報告

請參閱

概念

Configuration Manager 2007 的管理組件監視案例

其它資源

Configuration Manager 2007 管理組件概觀
部署 Configuration Manager 2007 管理組件
執行 Configuration Manager 2007 管理組件的操作工作


Configuration Manager 2007 管理組件的其他資源

以下是 System Center Configuration Manager 2007 管理組件可用的資源。

Microsoft Operations Manager 2007

若要存取網際網路上的 Operations Manager 2007 核心產品文件，或需要 System Center Operations Manager 2007 最新資訊，請參閱 Operations Manager 2007 產品網頁 (http://go.microsoft.com/fwlink/?LinkID=83259) (英文)。

System Center Configuration Manager 2007

所有部署和使用 Configuration Manager 2007 所需的資訊都已於核心產品文件、Configuration Manager 2007 系統管理員主控台說明、Configuration Manager 2007 詞彙以及 Configuration Manager 2007 線上文件庫中提供。Configuration Manager 2007 文件庫與 Configuration Manager 2007 系統管理員主控台說明可以從 Configuration Manager 2007 系統管理員主控台存取。

Configuration Manager 2007 線上文件庫

  • Configuration Manager 2007 文件庫提供部署和使用 Configuration Manager 2007 所需的資訊。文件庫是與 Configuration Manager 2007 一起安裝。

Configuration Manager 2007 網頁

  • 如需 Configuration Manager 2007 的最新相關資訊，請參閱 Configuration Manager 文件庫網頁 (http://go.microsoft.com/fwlink/?LinkId=98803) (英文)。
  • 如需更多協助，請參閱「Configuration Manager 支援」(http://go.microsoft.com/fwlink/?LinkId=98800) 網站上支援區段中的其他支援選項清單。
  • 若要搜尋 Microsoft 知識庫及其他技術資源，以取得 SMS 相關問題的快速精確解答，請瀏覽 Microsoft 技術支援服務網站。您可以使用指派給問題的 "Qxxxxxx" 編號或 "xxxxxx" 編號查詢知識庫，尋找關於特定問題的文章。

提供意見

  • 請提供您的意見和評論，幫助 Configuration Manager 2007 文件小組製作出對您而言最有價值的產品資訊。請將您對於我們文件的意見反應寄至 Configuration Manager。

請參閱

概念

Configuration Manager 2007 管理組件的站台與元件
Configuration Manager 2007 管理組件的電腦群組
Configuration Manager 2007 管理組件的安裝類別
Configuration Manager 2007 管理組件的指令碼
Configuration Manager 2007 管理組件的檢視
Configuration Manager 2007 管理組件的圖表
Configuration Manager 2007 管理組件的報告


Configuration Manager 2007 管理組件的站台與元件

System Center Configuration Manager 元件包含 Configuration Manager 中央站台伺服器、Configuration Manager 站台資料庫與 Configuration Manager 系統管理員主控台。Configuration Manager 中央站台伺服器、Configuration Manager 站台資料庫與 Configuration Manager 系統管理員主控台通常位於相同的伺服器上，且每個站台系統角色皆位於專屬伺服器。中央站台伺服器和資料庫加上任何站台系統角色後，即構成一個 Configuration Manager 站台。單一 Configuration Manager 站台可能包含多種重複的站台系統角色。Configuration Manager 2007 站台可以層疊。單一 Configuration Manager 站台可能不含某些站台伺服器角色，例如伺服器定位器點。

Configuration Manager 2007 管理組件的設計目的是監控 Configuration Manager 站台階層與其中的伺服器。此管理組件並不是設計來監控 Configuration Manager 用戶端上的 Configuration Manager 功能。但是，Operations Manager 2007 可用於監控位於 Configuration Manager 用戶端電腦上的其他應用程式。

如需更多關於 Configuration Manager 2007 元件的資訊，請參閱 Configuration Manager 線上文件庫。如需 Configuration Manager 文件的連結，請參閱本手冊中的 Configuration Manager 2007 管理組件的其他資源一節。

關鍵伺服器角色包括：

  • 發佈點
  • 管理點
  • 伺服器定位器點
  • 報告點
  • 軟體更新點
  • 站台伺服器
  • 站台資料庫
  • Configuration Manager 提供者
  • 行動裝置管理點
  • Configuration Manager 系統管理員主控台
  • 後援狀態點
  • PXE 服務點
  • 系統健康狀態驗證點
  • 伺服器定位器點
  • 狀態移轉點

發佈點

發佈點會儲存安裝由 Configuration Manager 發佈的軟體程式時 Configuration Manager 用戶端使用的 Configuration Manager 封裝來源檔案。當 Configuration Manager 系統管理員公告程式時，即可透過管理點將通告與程式資訊提供給用戶端。

設定 Configuration Manager 時，系統會自動為站台伺服器指派發佈點角色。Configuration Manager 系統管理員可以為發佈點啟用背景智慧型傳送服務 (BITS)，BITS 能讓用戶端在網路頻寬閒置時下載封裝檔案，而且支援續傳功能。

用戶端會使用 BITS 自動偵測用戶端網路連線能力，並有效地調整傳輸速度。只有執行 Microsoft Windows XP Professional、Microsoft Windows Server™ 2003 作業系統與 Windows Vista 作業系統的用戶端才支援此功能。

管理點

管理點是 Configuration Manager 用戶端和 Configuration Manager 站台伺服器間的主要連絡點。雖然可以利用 Windows Network Load Balancing Service 設定多個管理點，但 Configuration Manager 站台僅有一個預設管理點。管理點具備下列功能：

  • 在用戶端安裝後，為用戶端提供特定用戶端設定詳細資料。
  • 做為用戶端電腦檢查通告的位置。
  • 找出用戶端的發佈點。
  • 接收來自用戶端的清查、軟體計量和狀態資訊，並轉寄給 Configuration Manager 站台伺服器。

伺服器定位器點

伺服器定位器點可找出 Configuration Manager 用戶端的管理點。伺服器定位器點最常用於用戶端安裝。伺服器定位器點具備下列功能：

  • 如果用戶端設定為自動 Configuration Manager 站台指派，伺服器定位器點可以找出用戶端的管理點。
  • 在以登入指令碼啟動的用戶端安裝以及認證資料不足的安裝期間，為用戶端提供管理點的位置。

報告點

報告點是執行 Internet Information Services (IIS) (主控報告檢視器的程式碼以及任何補充報告) 的伺服器。報告點只與其 Configuration Manager 站台資料庫伺服器通訊。

軟體更新點

Configuration Manager 2007 中的軟體更新點是軟體更新的必要元件，而且是安裝為 Configuration Manager 主控台中的站台系統角色。軟體更新點站台系統角色必須建立在已安裝 Windows Server Update Services (WSUS) 3.0 而且與 WSUS 元件互動以配置更新設定的站台系統伺服器上，以要求與上游更新伺服器同步，以及將來自 WSUS 資料庫的更新同步到站台伺服器資料庫。

若要為軟體更新點與 Windows Server Update Services 啟用監控功能，請執行下列程序。

為軟體更新點與 Windows Server Update Services 啟用監控功能

  1. 在操作主控台中，按一下 [撰寫中]。

  2. 在瀏覽窗格中，瀏覽到 [撰寫中] > [管理組件物件]，然後按一下 [規則]。

  3. 在規則窗格中，搜尋要啟用的規則。若規則清單上方的 [尋找] 列無法使用，請瀏覽 [檢視]，然後按一下 [尋找]。

  4. 在要啟用之規則的名稱上按一下滑鼠右鍵，瀏覽到 [覆寫] > [覆寫規則]，然後按一下要由此規則監控的物件集合。

  5. 將 [Enabled] 屬性設定為 [真]，然後根據您環境需要修改任何閾值。按一下 [確定]。

站台伺服器

被指派至已成功執行 Configuration Manager 安裝程式之伺服器的 Configuration Manager 站台系統角色。在電腦上安裝 Configuration Manager 站台時，該電腦會自動被指派站台伺服器角色。每個 Configuration Manager 站台都有一個站台伺服器。

站台資料庫

被指派至裝載 Configuration Manager 站台資料庫 (SQL Server 資料庫) 之電腦的 Configuration Manager 站台系統角色。

Configuration Manager 提供者

Configuration Manager 提供者會處理來自 Configuration Manager 站台資料庫的資料要求。Configuration Manager 提供者角色會與 Configuration Manager 站台伺服器或 Configuration Manager 站台資料庫安裝在同一部電腦上。建議您在站台伺服器上同時安裝 Configuration Manager 提供者及 Configuration Manager 站台資料庫。Configuration Manager 提供者能讓安裝在站台上的 Configuration Manager 系統管理員主控台存取資料。

行動裝置管理點

裝置管理點是依存於 Configuration Manager 2007 管理點角色的站台角色。裝置管理點是 Configuration Manager 2007 Windows Mobile 裝置用戶端的通訊點，而且必須位於與 Configuration Manager 2007 管理點相同的電腦上。

Configuration Manager 系統管理員主控台

Configuration Manager 2007 系統管理員主控台是用於管理 Configuration Manager 的圖形化使用者介面。此介面會使用 Configuration Manager 產品軟體隨附的 Microsoft Management Console (MMC) 嵌入式管理單元。當您安裝主要站台伺服器時，依預設會安裝 Configuration Manager 系統管理員主控台。它也可以安裝在其他伺服器或工作站上。

後援狀態點

從無法正確安裝的用戶端、無法指派給 Configuration Manager 2007 站台的用戶端或無法尋找或與其受指派管理點通訊的用戶端收集狀態訊息的 Configuration Manager 站台系統。當用戶端正確安裝與指派時，狀態訊息也會傳送到後援狀態點。

PXE 服務點

Configuration Manager 2007 會使用 PXE 服務點站台角色來初始化作業系統部署程序。PXE 服務點必須設定為回應網路上 Configuration Manager 2007 用戶端發出之 PXE 開機要求，然後與 Configuration Manager 2007 基礎結構互動並判斷要採取的適當部署動作。

系統健康狀態驗證點

系統健康狀態驗證點是 Configuration Manager 2007 站台系統角色，它會在 Windows Server 2008 上與網路原則伺服器 (NPS) 角色一起運作。在 Configuration Manager 2007 中使用網路存取保護 (NAP) 時，需要系統健康狀態驗證點才能驗證來自支援 NAP 之 Configuration Manager 用戶端的健康狀態聲明，以產生用戶端健全狀況狀態相符或不相符，或導致無法判斷健全狀況狀態的錯誤情況。

伺服器定位器點

伺服器定位器點會用於 Configuration Manager 2007 階層以完成內部網路上的用戶端站台指派作業，並在用戶端無法透過 Active Directory 網域服務尋找管理點時協助用戶端尋找該資訊。內部網路用戶端會使用 Active Directory 網域服務做為其偏好的方式，以完成站台指派作業與管理點尋找作業。但是，如果未針對 Configuration Manager 2007 擴充 Active Directory 架構、站台未發佈至 Active Directory 網域服務，或用戶端不屬於與站台伺服器樹系所屬樹系相同的 Active Directory 樹系，則用戶端必須使用伺服器定位器點。

狀態移轉點

當 Configuration Manager 2007 作業系統部署將使用者狀態與設定從一部電腦移轉到另一部電腦 (以做為作業系統映像部署的一部分) 時會使用狀態移轉點。狀態移轉點要求系統上必須安裝 Internet Information Services。

請參閱

概念

Configuration Manager 2007 管理組件的其他資源
Configuration Manager 2007 管理組件的電腦群組
Configuration Manager 2007 管理組件的安裝類別
Configuration Manager 2007 管理組件的指令碼
Configuration Manager 2007 管理組件的檢視
Configuration Manager 2007 管理組件的圖表
Configuration Manager 2007 管理組件的報告


Configuration Manager 2007 管理組件的電腦群組

Configuration Manager 2007 管理組件提供下列電腦群組：

  • Microsoft ConfigMgr 2007 系統管理員主控台 - 已安裝系統管理員主控台的 ConfigMgr 2007 站台系統、成員伺服器或工作站。
  • Microsoft ConfigMgr 2007 進階用戶端 - 任何系統上安裝的 ConfigMgr 2007 進階用戶端。
  • Microsoft ConfigMgr 2007 分支發佈點伺服器 - 屬於分支發佈點伺服器的 ConfigMgr 2007 用戶端。
  • Microsoft ConfigMgr 2007 中央站台伺服器 - 屬於中央站台伺服器的 ConfigMgr 2007 站台伺服器。
  • Microsoft ConfigMgr 2007 用戶端 - 已安裝 ConfigMgr 2007 用戶端的電腦。
  • 以 IIS 為基礎的 Microsoft ConfigMgr 2007 元件伺服器 - 執行 IIS 服務的 ConfigMgr 2007 站台伺服器或站台系統。
  • 以 SMS Executive 為基礎的 Microsoft ConfigMgr 2007 元件伺服器 - 執行 SMS Executive 服務的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 裝置管理點伺服器 - 屬於裝置管理點的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 發佈點伺服器 - 屬於發佈點伺服器的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 後援狀態點伺服器 - 已安裝 ConfigMgr 後援狀態點的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 管理點伺服器 - 屬於管理點的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 主要站台伺服器 - 屬於主要站台伺服器的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 提供者 - 屬於 ConfigMgr 提供者的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 PXE 伺服器 - 屬於已安裝 ConfigMgr PXE 服務點之 Windows 部署服務伺服器的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 報告點伺服器 - 屬於報告點的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 次要站台伺服器 - 屬於次要站台伺服器的 ConfigMgr 2007 站台伺服器。
  • Microsoft ConfigMgr 2007 伺服器定位器點伺服器 - 屬於伺服器定位器點的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 伺服器 - ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 站台資料庫伺服器 - 屬於站台資料庫伺服器的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 站台伺服器 - 屬於主要或次要站台伺服器的 ConfigMgr 2007 站台伺服器。
  • Microsoft ConfigMgr 2007 軟體更新點伺服器 - 屬於已安裝 ConfigMgr 軟體更新點之 Windows Software Update Services 伺服器的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 標準發佈點伺服器 - 屬於標準發佈點伺服器的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 狀態移轉點伺服器 - 已安裝 ConfigMgr 狀態移轉點的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 系統健康狀態驗證伺服器 - 屬於已安裝 ConfigMgr 系統健康狀態驗證之 Internet Authentication Server 的 ConfigMgr 2007 站台系統。

請參閱

概念

Configuration Manager 2007 管理組件的其他資源
Configuration Manager 2007 管理組件的站台與元件
Configuration Manager 2007 管理組件的安裝類別
Configuration Manager 2007 管理組件的指令碼
Configuration Manager 2007 管理組件的檢視
Configuration Manager 2007 管理組件的圖表
Configuration Manager 2007 管理組件的報告


Configuration Manager 2007 管理組件的安裝類別

本節列出 System Center Configuration Manager 2007 管理組件中，適用於規則與監視等的安裝類別。請參閱 Operations Manager 2007 操作主控台中的 [撰寫中]，然後將領域設定為想要的特定類別。

  • Microsoft ConfigMgr 2007 系統管理員主控台 - 已安裝系統管理員主控台的 ConfigMgr 2007 站台系統、成員伺服器或工作站。
  • Microsoft ConfigMgr 2007 進階用戶端 - 任何系統上安裝的 ConfigMgr 2007 進階用戶端。
  • Microsoft ConfigMgr 2007 分支發佈點伺服器 - 屬於分支發佈點伺服器的 ConfigMgr 2007 用戶端。
  • Microsoft ConfigMgr 2007 中央站台伺服器 - 屬於中央站台伺服器的 ConfigMgr 2007 站台伺服器。
  • Microsoft ConfigMgr 2007 用戶端 - 已安裝 ConfigMgr 2007 用戶端的電腦。
  • 以 IIS 為基礎的 Microsoft ConfigMgr 2007 元件伺服器 - 執行 IIS 服務的 ConfigMgr 2007 站台伺服器或站台系統。
  • 以 SMS Executive 為基礎的 Microsoft ConfigMgr 2007 元件伺服器 - 執行 SMS Executive 服務的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 裝置管理點伺服器 - 屬於裝置管理點的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 發佈點伺服器 - 屬於發佈點伺服器的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 後援狀態點伺服器 - 已安裝 ConfigMgr 後援狀態點的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 管理點伺服器 - 屬於管理點的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 主要站台伺服器 - 屬於主要站台伺服器的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 提供者 - 屬於 ConfigMgr 提供者的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 PXE 伺服器 - 屬於已安裝 ConfigMgr PXE 服務點之 Windows 部署服務伺服器的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 報告點伺服器 - 屬於報告點的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 次要站台伺服器 - 屬於次要站台伺服器的 ConfigMgr 2007 站台伺服器。
  • Microsoft ConfigMgr 2007 伺服器定位器點伺服器 - 屬於伺服器定位器點的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 伺服器 - ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 站台資料庫伺服器 - 屬於站台資料庫伺服器的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 站台伺服器 - 屬於主要或次要站台伺服器的 ConfigMgr 2007 站台伺服器。
  • Microsoft ConfigMgr 2007 軟體更新點伺服器 - 屬於已安裝 ConfigMgr 軟體更新點之 Windows Software Update Services 伺服器的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 標準發佈點伺服器 - 屬於標準發佈點伺服器的 ConfigMgr 2007 站台伺服器或站台系統。
  • Microsoft ConfigMgr 2007 狀態移轉點伺服器 - 已安裝 ConfigMgr 狀態移轉點的 ConfigMgr 2007 站台系統。
  • Microsoft ConfigMgr 2007 系統健康狀態驗證伺服器 - 屬於已安裝 ConfigMgr 系統健康狀態驗證之 Internet Authentication Server 的 ConfigMgr 2007 站台系統。

請參閱

概念

Configuration Manager 2007 管理組件的其他資源
Configuration Manager 2007 管理組件的站台與元件
Configuration Manager 2007 管理組件的電腦群組
Configuration Manager 2007 管理組件的指令碼
Configuration Manager 2007 管理組件的檢視
Configuration Manager 2007 管理組件的圖表
Configuration Manager 2007 管理組件的報告


Configuration Manager 2007 管理組件的指令碼

Configuration Manager 2007 管理組件包含 Operations Manager 2007 指令碼，這些指令碼包括於代理程式上自動執行的指令碼，以及需要由系統管理員執行的指令碼。本節稍後的內容會說明其中部分指令碼的其他相關資訊。

下列指令碼由 Operations Manager 2007 代理程式自動執行：

  • ConfigMgr 2007 Monitor Collection Evaluation Tasks
  • ConfigMgr 2007 Monitor Component Health
  • ConfigMgr 2007 Monitor NLB Management Point Health
  • ConfigMgr 2007 Monitor Server Health
  • ConfigMgr 2007 Monitor Site Maintenance Tasks
  • ConfigMgr 2007 Monitor Site System Summarizer
  • ConfigMgr 2007 Monitor SMS Executive Crash Dumps
  • ConfigMgr 2007 Monitor SMS Inbox
  • ConfigMgr 2007 Monitor SMS Status Messages
  • ConfigMgr 2007 Monitor State Message Summary Tasks
  • ConfigMgr 2007 Service Discovery - Client
  • ConfigMgr 2007 Service Discovery - Server
  • ConfigMgr 2007 Site Hierarchy Discovery

ConfigMgr 2007 Monitor SMS Status Messages

Configuration Manager 2007 中許多問題是透過 SMS 狀態系統進行內部偵測與報告。狀態訊息是由與 Configuration Manager 2007 系統管理員所關注之狀況相關的 Configuration Manager 2007 元件所產生。

狀態訊息會傳送至 Configuration Manager 2007 的資料庫，並往上傳至站台階層進入父站台的資料庫。您僅需查詢特定站台資料庫的 Configuration Manager 2007 狀態訊息表，即可監控個別站台的 Configuration Manager 2007 狀態系統。

有一組選出用以監控的狀態訊息，可以向 Configuration Manager 2007 系統管理員反映出最嚴重事件。當資料庫中出現其中任何一個訊息時，會產生警示。

此指令碼會進行下列作業：

  • 檢查其是否於無代理程式管理模式下執行。如果是，指令碼會結束而不進行進一步的動作。
  • 初始化全域變數。
  • 從 ConfigMgr 2007 Monitor SMS Status Messages.VarSet 檔案，開啟並讀取每個受監控的 Configuration Manager 站台資料庫最後處理之狀態訊息的記錄識別碼。
  • 處理本機電腦上每個 Configuration Manager 2007 站台資料庫中的狀態訊息。
  • 為受監控的 Configuration Manager 2007 站台資料庫將最後處理之狀態訊息的記錄識別碼寫入 ConfigMgr 2007 Monitor SMS Status Messages.SCOM2007.VarSet 檔案並關閉檔案。

ConfigMgr 2007 Monitor SMS Status Messages 指令碼會產生事件，並將事件識別碼設為報告的 SMS 狀態訊息識別碼。下表說明產生之事件的格式。

ConfigMgr 2007 Monitor SMS Status Messages 指令碼所產生之事件的格式

參數 | 說明
EventType | 視 SMS 狀態訊息嚴重性而定，分別為成功、錯誤、警告或資訊
EventNumber | SMS 狀態訊息識別碼
Category | ConfigMgr 站台碼
LoggingDomain | 電腦資源網域
LoggingComputer | 電腦的 NetBIOS 名稱
Parameter1 | 電腦的 NetBIOS 名稱
Parameter2 | ConfigMgr 模組名稱—例如，ConfigMgr Server
Parameter3 | ConfigMgr 元件名稱
Parameter4 | SMS 訊息識別碼
Parameter5 | Win32 錯誤碼
Parameter6 | 上層或最上層站台碼
Parameter7 | SMS 狀態訊息表中狀態訊息的記錄識別碼
Description | 站台 <Site Code> 資料庫中出現 <NetBIOS Name> 電腦中 <Component Name> 元件的新監控 SMS 狀態訊息 (訊息識別碼為 <Message ID>)。

ConfigMgr 2007 Monitor SMS Status Messages 指令碼也會以狀態訊息識別碼編號 1102 報告指令碼錯誤：

EventType= Warning (事件類型= 警告)

EventNumber= 1102 (事件編號= 1102)

Description = The script ConfigMgr 2007 Monitor SMS Status Messages running under processing rule <ScriptProcessingRuleName> encountered a runtime error.The error message will contain the text "Failed to <ErrorDescription>."

所有 ConfigMgr 2007 狀態訊息監視事件規則都會以「ConfigMgr 2007 狀態:」開頭而且會與「ConfigMgr 站台資料庫伺服器」類別關聯。

  • ConfigMgr 2007 狀態:訊息監視

ConfigMgr 2007 狀態:訊息監視每隔 30 分鐘會啟動指令碼 (於 00:02同步)。摘要資訊會於規則的 [Knowledge] 內容頁中提供。

附註
ConfigMgr 2007 狀態:訊息監視在監視的表格中有許多歷史資料存在的情況下，將需要非常久的時間才能執行完畢。此查詢的最佳實作是適時清除狀態訊息，以避免執行時間過長。

  • ConfigMgr 2007 狀態:指令碼錯誤

ConfigMgr 2007 狀態:指令碼錯誤會監視任何可能產生的指令碼錯誤事件並發出警示。只有一個指令碼錯誤事件 (其編號為 1102)，它會報告所有指令碼錯誤。警示解決方式的相關資訊會於規則的 [Knowledge] 內容頁中提供。

  • ConfigMgr 2007 狀態: <status message name>

ConfigMgr 2007 狀態:<狀態訊息名稱>會監視特定狀態訊息事件並發出警示。警示解決方式的相關資訊會於規則的 [Knowledge] 內容頁中提供。

所有警示都具有下列格式的事件說明，其中 $Description$ 為事件說明：

$Logging Computer$ - "Rule Name"。$Description$

ConfigMgr 2007 Monitor SMS Status Messages VarSet 檔案是用來保留最後一個針對站台處理之狀態訊息的記錄識別碼。VarSet 檔案位於 TMP 環境變數所指定的資料夾。這是一個 Tab 分隔的檔案，格式如下：

複製程式碼
LastRecordID_DBNameRecordID#

例如，記錄識別碼為 477860 的 LastRecordID_SMS_FLA 代表名稱為 SMS_FLA 的站台資料庫最後處理的記錄識別碼為 477860。

從先前版本升級管理組件時，下列資訊會顯示於 ConfigMgr 2007 Monitor SMS Status Messages VarSet 檔案中：

複製程式碼
LastRecordID476743
LastRecordID_SMS_FLA477860

第一行 (不包含資料庫名稱) 代表不支援多資料庫監控的原始版本狀態訊息監視。第二行 (包含資料庫名稱 SMS_FLA) 代表支援多資料庫監視的目前版本狀態訊息監視。

使用第一行資料不會執行任何動作，因為在多站台資料庫的情況中，很難判斷應該對應哪個資料庫。第一行資料不會從 VarSet 檔案中移除，因為在評估新變更與確認升級後狀態訊息監視會以正確的記錄識別碼開頭方面，這項資料可能很有用。在 Configuration Manager 2007 中，存取站台資料庫的所有指令碼都會從站台伺服器執行，以支援 SQL 叢集。這與 SMS 2003 中的運作方式不同，在 SMS 2003 中，指令碼都會從 SQL Server 本機執行。因此，Configuration Manager 2007 站台資料庫伺服器將會與探索到的 Microsoft Configuration Manager 站台伺服器執行個體相同。

ConfigMgr 2007 Monitor Site System Summarizer

站台系統摘要器

站台系統狀態摘要器為 SMS Executive 服務的元件執行緒，可維護所有定義的 Configuration Manager 2007 站台系統狀態。依照預設，它會於目前狀態期間每小時輪詢一次。這個輪詢間隔會於 Configuration Manager 2007 站台控制檔案中定義。建議您不要變更輪詢間隔。狀態會於 Configuration Manager 2007 站台資料庫中的資料表內維護。

站台系統 DownSince 狀態

當站台無法於任何一個輪詢間隔期間連絡站台系統時，站台系統狀態摘要器會假定站台停機。這可能是由於下列其中一個原因所造成：

  • 站台系統未啟動、未連至網路或未正常運作。
  • ConfigMgr 2007 站台系統狀態摘要器無法連線，因為沒有可以使用的連線。
  • ConfigMgr 2007 站台系統狀態摘要器沒有足夠的存取權限可以連接站台系統。
  • 網路問題使 ConfigMgr 2007 站台系統狀態摘要器無法連接站台系統。
  • 站台系統已永久失效。

DownSince 值是 Summarizer_SiteSystem 站台資料庫資料表中的資料行。

條件約束如下：

  • 站台系統摘要器輪詢間隔為 1 小時。此間隔能讓站台系統狀態摘要器有足夠時間輪詢所有站台系統。為了保持效能之故，間隔不能變更。摘要器的逾時間隔是由站台控制檔案中的 Startup Schedule 屬性所控制，而非由 Wakeup Interval 屬性所控制。這表示變更 Wakeup Interval 屬性的預設值 60 不會有效果。此外，變更 Startup Schedule 也不會有效果。依照預設，此屬性的間隔設為 60 分鐘，而站台系統狀態摘要器會每小時 (整點) 輪詢站台系統一次，不論 Startup Schedule 的設定為何。
  • 只有當過去 2 小時之內發生兩個連續的 ConfigMgr 2007 站台系統摘要器:站台系統可能停機事件時，才會產生警示。這是為了暫時性網路中斷的考量而設計。
  • Configuration Manager 2007 可能會發生許多無法使用的情況，使得站台系統狀態摘要器無法監視其狀態。例如，當 SQL Server 服務停止時，如果 SMS 服務未執行或 Configuration Manager 2007 站台資料庫無法使用，站台系統狀態摘要器不會認定 Configuration Manager 無法使用。
  • 站台系統狀態摘要器會為電腦上的每個站台物件和站台系統角色，將目前的 "DownSince" 狀態寫入資料庫的站台系統狀態摘要器資料表中。

監視指令碼的站台系統狀態摘要器會檢查站台系統狀態摘要器資料表中的每個站台系統角色。如果某個站台系統標示為停機，即會產生事件。隨即會根據事件產生警示。多個角色可能會產生多個警示。

每個 Configuration Manager 2007 伺服器角色 (除了 Configuration Manager 2007 發佈點以外) 依預設會建立兩個 Configuration Manager 2007 伺服器角色，一個用於特定角色，另一個用於 Configuration Manager 2007 元件伺服器。例如，在站台系統同時裝載伺服器定位器點和報告點的情況下，如果伺服器離線超過 2 小時 (兩個站台系統狀態摘要器輪詢間隔)，站台系統狀態摘要器會將此兩個角色以及它們的 Configuration Manager 元件伺服器角色都標示為停機。

不過，2 小時期間內每個輪詢間隔僅會產生三個警示 (兩個用於各個伺服器角色，一個用於裝載兩個伺服器角色的實體元件伺服器)。

  • 60 分的排程 (整點過後 10 分鐘) 已設為預設，因此 ConfigMgr 2007 Monitor Site System Summarizer 指令碼會於站台系統狀態摘要器 1 小時輪詢間隔開始 10 分鐘後執行。如果摘要器耗時超過 10 分鐘完成其循環，定時的事件提供者偏移應會適當增加。否則，最新的站台系統狀態訊息會遺漏。

ConfigMgr 2007 Monitor SMS Executive Crash Dumps 指令碼

此指令碼會採取下列動作：

  • 判斷目標電腦是否以無代理程式模式執行。如果是，指令碼會結束而不進行進一步的動作。此指令碼會使用本機 VarSet 檔案保存變數，因此必須在執行 SMS Executive 服務的所有目標電腦上安裝 Operations Manager 2007 代理程式。
  • 開啟本機 ConfigMgr 2007 Monitor SMS Executive Crash Dumps.SCOM2007.VarSet 檔案 (位於 TMP 環境變數所指定的路徑下)，並將內容讀取到集合中。如果檔案不存在，就不會產生指令碼錯誤事件。如果檔案存在但無法開啟，會產生指令碼錯誤事件，並出現包含下列文字的訊息：

Failed to load script variables. (無法載入指令碼變數。)

  • 檢查自上一次執行檢查後，是否發生新的損毀傾印。如果有，指令碼會產生事件以報告新的損毀傾印。為產生指令碼錯誤事件，指令碼會進行下列作業：
    • 從 SMS Identification 機碼下的登錄取得 ConfigMgr 安裝目錄，登錄值為 "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\ Installation Directory"。如果無法取得路徑，指令碼會產生包含下列文字的指令碼錯誤事件訊息並結束：

Failed to read registry value. (無法讀取登錄值。)

  • 將 "\Logs\CrashDumps" 附加到取得的 Configuration Manager 安裝目錄中，建構 CrashDumps 目錄的完整路徑。
  • 檢查 CrashDumps 目錄是否存在。如果該目錄不存在，指令碼會結束而不進行進一步的動作。
  • 如果 CrashDump 目錄存在，它會從 VarSet 集合取得上次損毀傾印資料夾的建立日期。
  • 檢查是否建立了新的損毀傾印並僅針對最新的損毀傾印進行作業。為判斷最新的損毀傾印，會使用最後的損毀傾印儲存的資料夾建立日期 (如果有的話)。日期和時間比對是以資料夾的建立時間 (最小單位為 1 秒鐘) 為基礎。
  • 如果發生新的損毀傾印或首次執行指令碼，指令碼會記錄並建立事件 1710，指定新的損毀傾印資料夾和路徑。指令碼會在 VarSet 集合中儲存損毀傾印資料夾建立日期。
  • 將 VarSet 集合內容寫入本機 ConfigMgr 2007 Monitor SMS Executive Crash Dumps.SCOM2007.VarSet 檔案並關閉檔案。如果檔案不存在，會加以建立。如果沒有設定 VarSet 變數，則檔案中不會出現變數項目。如果寫入檔案時發生錯誤，會產生包含下列文字的指令碼錯誤事件訊息：Failed to save script variables. (無法儲存指令碼變數。)

ConfigMgr 2007 Monitoring SMS Executive Crash Dump Event

ConfigMgr 2007 Monitor SMS Executive Crash Dumps 指令碼會透過事件 1710 報告已發生損毀，如下所述：

EventType = Error (事件類型 = 錯誤)

EventNumber= 1710 (事件編號= 1710)

Category = SMS Site Code (類別 = SMS 站台碼)

Description = SMS Executive in site “XXX” has crashed.For details, see crash dump information under <Drive> <ConfigMgrInstallationPath>\Logs\CrashDumps\NewFolder.

ConfigMgr 2007 Monitoring SMS Executive Crash Dumps 指令碼錯誤事件

SMS 2003 Monitor SMS Executive Crash Dumps 指令碼會透過事件 1102 報告執行階段指令碼錯誤。

EventType= Warning (事件類型= 警告)

EventNumber= 1102 (事件編號= 1102)

Description = The script 廍MS 2003 Monitor SMS Executive Crash Dumps?running under processing rule SMS 2003 Crash Dumps:Monitoring SMS Executive encountered a runtime error.CrLf “Failed to <Message>." ErrorString

請參閱

概念

Configuration Manager 2007 管理組件的其他資源
Configuration Manager 2007 管理組件的站台與元件
Configuration Manager 2007 管理組件的電腦群組
Configuration Manager 2007 管理組件的安裝類別
Configuration Manager 2007 管理組件的檢視
Configuration Manager 2007 管理組件的圖表
Configuration Manager 2007 管理組件的報告


Configuration Manager 2007 管理組件的檢視

Configuration Manager 2007 管理組件提供下列一般檢視：

  • 警示
  • 電腦狀態
  • 事件
  • 站台階層圖表
  • 站台階層狀態
  • 站台狀態
  • 工作狀態
  • 與下列類別檢視資料夾
  • 一般
  • 效能

一般

  • 中央站台伺服器於過去 72 小時內發出的警示
  • 過去 72 小時內新增的警示

效能檢視

您可以將檢視設定為以預覽方式顯示特定電腦的資料。個別選擇相關電腦的計數器，可以降低圖表的複雜度。

待處理項目\管理點伺服器

  • 過去 48 小時內的 DDR 待處理項目
  • 過去 48 小時內的 FileCollection 待處理項目
  • 過去 48 小時內的 HINV 待處理項目
  • 過去 48 小時內的寄件匣 ddr.box 待處理項目
  • 過去 48 小時內的寄件匣 distmgr.box 待處理項目
  • 過去 48 小時內的寄件匣 hinv.box 待處理項目
  • 過去 48 小時內的寄件匣 rdr.box 待處理項目
  • 過去 48 小時內的寄件匣 sinv.box 待處理項目
  • 過去 48 小時內的寄件匣 stat.box 待處理項目
  • 過去 48 小時內的寄件匣 statemsg.box 待處理項目
  • 過去 48 小時內的寄件匣 swm.box 待處理項目
  • 過去 48 小時內的 Relay 待處理項目
  • 過去 48 小時內的 SINV 待處理項目
  • 過去 48 小時內的狀態 待處理項目

待處理項目\PXE 服務點伺服器

  • 過去 24 小時內的待處理資料庫要求

待處理項目\以 SMS Executive 為基礎的伺服器

  • 過去 48 小時內的寄件匣 stat.box 待處理項目
  • 過去 48 小時內的寄件匣 statemsg.box 待處理項目

待處理項目\站台伺服器

  • 過去 48 小時內的 DDR 待處理項目
  • 過去 48 小時內的 HINV 待處理項目
  • 收件匣驗證/過去 48 小時內的 dataldr.box 待處理項目
  • 收件匣驗證/過去 48 小時內的 ddm.box 待處理項目
  • 收件匣驗證/過去 48 小時內的 sinv.box 待處理項目
  • 收件匣驗證/過去 48 小時內的 statesys.box 待處理項目
  • 過去 48 小時內的收件匣 ciamgr.box 待處理項目
  • 過去 48 小時內的收件匣 ciamgr.box/RETRY.box 待處理項目
  • 過去 48 小時內的收件匣 compsumm.box/repl 待處理項目
  • 過去 48 小時內的收件匣 dataldr.box 待處理項目
  • 過去 48 小時內的收件匣 ddm.box 待處理項目
  • 過去 48 小時內的收件匣 despoolr.box/receive 待處理項目
  • 過去 48 小時內的收件匣 objmgr.box/INCOMING 待處理項目
  • 過去 48 小時內的收件匣 objmgr.box/INCOMING/Retry 待處理項目
  • 過去 48 小時內的收件匣 offermgr.box/INCOMING 待處理項目
  • 過去 48 小時內的收件匣 offersum.box/repl 待處理項目
  • 過去 48 小時內的收件匣 schedule.box/outboxes/LAN 待處理項目
  • 過去 48 小時內的收件匣 schedule.box/requests 待處理項目
  • 過去 48 小時內的收件匣 sinv.box 待處理項目
  • 過去 48 小時內的收件匣 sitestat.box/repl 待處理項目
  • 過去 48 小時內的收件匣 statmgr.box/statmsgs 待處理項目
  • 過去 48 小時內的收件匣 swmproc.box/usage 待處理項目
  • 過去 48 小時內的收件匣 WOLCMGR.box 待處理項目
  • 過去 48 小時內的收件匣 WOLCMGR.box/data 待處理項目
  • 過去 48 小時內的排程器工作待處理項目
  • 過去 48 小時內的排程器傳送要求待處理項目
  • 過去 48 小時內的 SINV 待處理項目
  • 過去 48 小時內的 SWM 待處理項目
  • 過去 48 小時內的擱置中 WOL 要求總數

條件\狀態移轉點伺服器

  • 過去 1 小時內的可用磁碟空間總計

條件\系統健康狀態驗證伺服器

  • 過去 24 小時內的修補程式 CookieInvalid
  • 過去 24 小時內的修補程式 CookieMissing
  • 過去 24 小時內的修補程式 CookieNew
  • 過去 24 小時內的修補程式 CookieNull
  • 過去 24 小時內的修補程式 CookieOld
  • 過去 24 小時內的修補程式 CookieSame
  • 過去 24 小時內的未安裝修補程式數目
  • 過去 24 小時內停用的 SMS NAP 用戶端代理程式
  • 過去 24 小時內的 SoH 過期絕對日期
  • 過去 24 小時內的 SoH 過期 TTL

一般\<伺服器類型>

下列檢視可用於管理點伺服器、PXE 服務點伺服器、站台伺服器、軟體更新點伺服器、狀態移轉點伺服器與系統健康狀態驗證伺服器。

  • 過去 48 小時內的 LogicalDisk
  • 過去 48 小時內的記憶體
  • 過去 48 小時內的處理器

處理速度

  • *過去 24 小時內 ConfigMgr 2007 管理點伺服器上所有訊息的處理速度
  • *過去 24 小時內 ConfigMgr 2007 管理點伺服器上所有報告的處理速度
  • *過去 24 小時內 ConfigMgr 2007 站台伺服器上所有報告的處理速度

處理速度\管理點伺服器

  • 過去 24 小時內每秒的 DDR 數
  • 過去 24 小時內每秒的 DM 資料庫連線嘗試數
  • 過去 24 小時內每秒的 DM DDR 數
  • 過去 24 小時內每秒的 DM 探索轉譯要求數
  • 過去 24 小時內每秒的 DM DP 位置數
  • 過去 24 小時內每秒的 DM 硬體清查轉譯要求數
  • 過去 24 小時內每秒的 DH HINV 數
  • 過去 24 小時內每秒的 DM ISAPI 要求數
  • 過去 24 小時內每秒的 DM 電腦設定要求數
  • 過去 24 小時內每秒的 DM 封裝版本要求數
  • 過去 24 小時內每秒的 DM SINV 數
  • 過去 24 小時內每秒的 DM 軟體原則內容要求數
  • 過去 24 小時內每秒的 DM 軟體原則 ID 要求數
  • 過去 24 小時內每秒的 DM 狀態
  • 過去 24 小時內每秒的 DM 總設定要求數
  • 過去 24 小時內每秒的 DP 位置數
  • 過去 24 小時內每秒的 Get SDM 封裝要求失敗數
  • 過去 24 小時內每秒的 Get SDM 封裝要求數
  • 過去 24 小時內每秒的 GetAuth 要求數
  • 過去 24 小時內每秒的 GetPolicy 要求數
  • 過去 24 小時內每秒的 HINV 數
  • 過去 24 小時內每秒的 ISAPI 要求數
  • 過去 24 小時內每秒的 MP 位置數
  • 過去 24 小時內每分鐘複製的寄件匣 ddr.box 檔案數
  • 過去 24 小時內的寄件匣 ddr.box 檔案複製失敗總數
  • 過去 24 小時內的寄件匣 ddr. box 檔案複製總數
  • 過去 24 小時內每分鐘複製的寄件夾 distmgr.box 檔案數
  • 過去 24 小時內的寄件匣 distmgr.box 檔案複製失敗總數
  • 過去 24 小時內的寄件夾 distmgr.box 檔案複製總數
  • 過去 24 小時內每分鐘複製的寄件匣 hinv.box 檔案數
  • 過去 24 小時內的寄件匣 hinv.box 檔案複製失敗總數
  • 過去 24 小時內的寄件夾 hinv.box 檔案複製總數
  • 過去 24 小時內每分鐘複製的寄件匣 rdr.box 檔案數
  • 過去 24 小時內的寄件匣 rdr.box 檔案複製失敗總數
  • 過去 24 小時內的寄件夾 rdr.box 檔案複製總數
  • 過去 24 小時內每分鐘複製的寄件匣 sinv.box 檔案數
  • 過去 24 小時內的寄件匣 sinv.box 檔案複製失敗總數
  • 過去 24 小時內的寄件夾 sinv.box 檔案複製總數
  • 過去 24 小時內每分鐘複製的寄件匣 stat. box 檔案數
  • 過去 24 小時內的寄件匣 stat.box 檔案複製失敗總數
  • 過去 24 小時內的寄件夾 stat.box 檔案複製總數
  • 過去 24 小時內每分鐘複製的寄件匣 statemsg.box 檔案數
  • 過去 24 小時內的寄件匣 statemsg.box 檔案複製失敗總數
  • 過去 24 小時內的寄件夾 statemsg.box 檔案複製總數
  • 過去 24 小時內每分鐘複製的寄件匣 swm, box 檔案數
  • 過去 24 小時內的寄件匣 swm.box 檔案複製失敗總數
  • 過去 24 小時內的寄件夾 swm.box 檔案複製總數
  • 過去 24 小時內每秒的 PA 要求數
  • 過去 24 小時內每秒的中繼報告數
  • 過去 24 小時內的伺服器可用性 DMP 平均要求延遲
  • 過去 24 小時內的伺服器可用性 DMP 失敗要求數
  • 過去 24 小時內的伺服器可用性 DMP 成功要求數
  • 過去 24 小時內的伺服器可用性 DMP 要求總數
  • 過去 24 小時內的伺服器可用性 MP 成功要求數：
  • 過去 24 小時內的伺服器可用性 MP 要求總數
  • 過去 24 小時內每秒的 SINV 數
  • 過去 24 小時內每秒所執行的 SP 數
  • 過去 24 小時內每秒處理的狀態訊息數
  • 過去 24 小時內拒絕的狀態訊息數：
  • 過去 24 小時內每秒的狀態數
  • 過去 24 小時內的 DDR 總數
  • 過去 24 小時內的 DM DDR 總數
  • 過去 24 小時內的 DM HINV 總數
  • 過去 24 小時內已發送的 DM ISAPI 要求總數
  • DM ISAPI 要求總數：於過去 24 小時內所接收
  • 過去 24 小時內的 DM SINV 總數
  • 過去 24 小時內的 DM 狀態總數
  • 過去 24 小時內失敗的 Get SDM 封裝要求總數
  • 過去 24 小時內的 Get SDM 封裝要求總數
  • 過去 24 小時內的 HINV 總數
  • 過去 24 小時內的中繼報告總數
  • 過去 24 小時內的 SINV 總數
  • 過去 24 小時內已處理的狀態訊息總數
  • 過去 24 小時內的狀態總數

處理速度\PXE 服務點伺服器

  • 過去 24 小時內已處理的資料庫要求數
  • 過去 24 小時內每秒處理的資料庫要求數
  • 過去 24 小時內已處理的 DHCP 探索要求數
  • 過去 24 小時內每秒處理的 DHCP 探索要求數
  • 過去 24 小時內已處理的 PXE 要求數
  • 過去 24 小時內每秒處理的 PXE 要求數
  • 過去 24 小時內的伺服器可用性 PSP 平均要求延遲
  • 過去 24 小時內的伺服器可用性 PSP 失敗要求數
  • 過去 24 小時內的伺服器可用性 PSP 成功要求數
  • 過去 24 小時內的伺服器可用性 PSP 要求總數
  • 過去 24 小時內取消的要求總數
  • 過去 24 小時內的要求總數
  • 過去 24 小時內每秒的要求總數

處理速度\以 SMS Executive 為基礎的伺服器

  • 過去 24 小時內每分鐘複製的寄件匣 stat.box 檔案數
  • 過去 24 小時內的寄件匣 stat.box 檔案複製失敗總數
  • 過去 24 小時內的寄件夾 stat.box 檔案複製總數
  • 過去 24 小時內每分鐘複製的寄件匣 statemsg.box 檔案數
  • 過去 24 小時內的寄件匣 statemsg.box 檔案複製失敗總數
  • 過去 24 小時內複製的寄件夾 statemsg.box 檔案數

處理速度\站台伺服器

  • 過去 24 小時內平均每分鐘寫入的更新數
  • 過去 24 小時內每分鐘的 DDR 數
  • 過去 24 小時內每分鐘的 HINV 數
  • 過去 24 小時內每秒的 WOL 封包數
  • 過去 24 小時內每分鐘的 SINV 數
  • 過去 24 小時內的狀態訊息檔案處理執行緒數
  • 過去 24 小時內每分鐘處理的狀態訊息檔案數
  • 過去 24 小時內每分鐘處理的狀態訊息記錄數
  • 過去 24 小時內每分鐘的狀態數
  • 過去 24 小時內每分鐘的 SWM 數
  • 過去 24 小時內處理的損壞狀態訊息檔案總數
  • 過去 24 小時內的 DDR 總數
  • 過去 24 小時內的 HINV 總數
  • 過去 24 小時內處理的無效狀態訊息記錄總數
  • 過去 24 小時內的失敗 WOL 封包總數
  • 過去 24 小時內的已傳送 WOL 封包總數
  • 過去 24 小時內的 SINV 總數
  • 過去 24 小時內已處理的狀態訊息檔案總數
  • 過去 24 小時內已放棄的狀態訊息記錄總數
  • 過去 24 小時內已處理的狀態訊息記錄總數
  • 過去 24 小時內的狀態總數
  • 過去 24 小時內的 SWM 總數
  • 過去 24 小時內已寫入的更新總數

處理速度\狀態移轉點伺服器

  • 過去 1 小時內目前已完成儲存狀態的用戶端數
  • 過去 1 小時內目前正在還原狀態的用戶端數
  • 過去 1 小時內目前正在儲存狀態的用戶端數
  • 過去 24 小時內的伺服器可用性 SMP 平均要求延遲
  • 過去 24 小時內的伺服器可用性 SMP 失敗要求數
  • 過去 24 小時內的伺服器可用性 SMP 成功要求數
  • 過去 24 小時內的伺服器可用性 SMP 要求總數
  • 過去 1 小時內已拒絕的用戶端總數

處理速度\系統健康狀態驗證伺服器

  • 過去 24 小時內每秒的 SoH 要求數
  • 過去 24 小時內的 SoH 要求總數
  • 過去 24 小時內的 SoH 回應用戶端脆弱數
  • 過去 24 小時內的 SoH 回應相容數
  • 過去 24 小時內的 SoH 回應失敗數
  • 過去 24 小時內的 SoH 回應不相容數
  • 過去 24 小時內的 SoH 回應伺服器脆弱數
  • 過去 24 小時內的 SoH 回應不明數

請參閱

概念

Configuration Manager 2007 管理組件的其他資源
Configuration Manager 2007 管理組件的站台與元件
Configuration Manager 2007 管理組件的電腦群組
Configuration Manager 2007 管理組件的安裝類別
Configuration Manager 2007 管理組件的指令碼
Configuration Manager 2007 管理組件的圖表
Configuration Manager 2007 管理組件的報告


Configuration Manager 2007 管理組件的圖表

Configuration Manager 2007 管理組件提供 Configuration Manager 2007 站台階層的圖表。圖表中會顯示站台伺服器和站台系統間的關係以及相關資訊。此拓撲圖表包含邏輯資料 (例如階層與站台) 與實體資料 (例如站台伺服器和站台系統)。因為 Configuration Manager 2007 階層可能很多，所以圖表有下列需求：

  • 您必須在所有中心站台伺服器與其 SMS 提供者上以本機方式安裝 Operations Manager 2007 代理程式。
  • 根據想要的 Configuration Manager 站台階層數，由上至下在所有主要站台伺服器上安裝 Operations Manager 2007 代理程式。
  • 每個安裝的 Operations Manager 2007 代理程式都必須啟用 Proxy 處理。
  • 對於 Operations Manager 所要探索的每部伺服器，使用 Configuration Manager 2007 系統管理員主控台輸入完整網域名稱 (FQDN)。
  • Configuration Manager 伺服器必須能被探索，而且必須出現在 Configuration Manager 系統管理員主控台的 [All Systems] 集合內。
  • 服務探索必須已找到 ConfigMgr 伺服器執行個體。

下列兩個指令碼可以執行探索。

  • ConfigMgr 2007 Service Discovery - Server
  • ConfigMgr 2007 Site Hierarchy Discovery

服務探索會找到 ConfigMgr Server 類別的執行個體。Site Hierarchy Discovery 會找到下列項目：

  • 站台—來自主要站台提供者的個別站台上的中央、主要以及次要站台
  • 網站間的關聯性
  • 站台內的伺服器
  • 站台伺服器與站台系統的關聯性

在圖表中可以看見部分探索資料，而透過物件內容則可看見更完整的資料。此外，您可以使用 .jpeg、.bmp 或 .png 檔案格式來儲存圖表。

請參閱

概念

Configuration Manager 2007 管理組件的其他資源
Configuration Manager 2007 管理組件的站台與元件
Configuration Manager 2007 管理組件的電腦群組
Configuration Manager 2007 管理組件的安裝類別
Configuration Manager 2007 管理組件的指令碼
Configuration Manager 2007 管理組件的檢視
Configuration Manager 2007 管理組件的報告


Configuration Manager 2007 管理組件的報告

本節中說明的報告可以在 Configuration Manager 2007 管理組件中找到。報告是必須單獨安裝的選用 Operations Manager 元件。如需更多關於部署報告伺服器的資訊，請參閱 Operations Manager 2007 產品網頁 (http://go.microsoft.com/fwlink/?LinkID=83259 (英文))。

Configuration Manager 2007 報告

Configuration Manager 2007 管理組件包括三種類型的報告：

  • 可用性
  • 設定
  • 效能

報告會使用物件選擇器分為群組或物件。所有報告皆為連結報告，會運用 Operations Manager 2007 報告功能。您可以從七種可匯出的格式中為報告選擇所需格式。

可用性報告

Configuration Manager 2007 管理組件中的「可用性」報告的目標是 ConfigMgr Server 類別與其監視。您可以選取 [Microsoft.SystemCenter.ConfigurationManager.2007.ServersGroup] 群組或報告之物件選擇器中的 [Microsoft.SystemCenter.ConfigurationManager.2007.SMS_Server_Class] 物件來執行此報告。

伺服器可用性

此報告是以特定伺服器上所有實體的彙總健全狀況狀態為基礎，而且將包含 System.Health.EntityState 的可用性健全狀態。

發佈點可用性

此報告是以發佈點的可用性健全狀況狀態為基礎，而且會使用來自 DP 健康狀態監視器的資訊。

管理點可用性

此報告是以管理點的可用性健全狀況狀態為基礎，而且會使用來自 MP 健康狀態監視器的資訊。

PXE 服務點可用性

此報告是以 PXE 服務點 的可用性健全狀況狀態為基礎，而且會使用來自 PSP 健康狀態監視器的資訊。

站台伺服器可用性

此報告是以站台伺服器的可用性健全狀況狀態為基礎，而且會使用來自 SS 健康狀態監視器的資訊。

軟體更新點可用性

此報告是以軟體更新點的可用性健全狀況狀態為基礎，而且會使用來自 SUP 健康狀態監視器的資訊。

系統健康狀態驗證可用性

此報告是以系統健康狀態驗證點的可用性健全狀況狀態為基礎，而且會使用來自 SHV 健康狀態監視器的資訊。

設定報告

Configuration Manager 2007 管理組件有一種設定報告可用，即 Configuration Manager 2007 伺服器自訂設定報告。此報告會顯示下列 ConfigMgr Server 類別內容：

  • 版本 (Configuration Manager 2007 產品版本)
  • 站台系統類型 (站台系統類型、伺服器類型、資料庫伺服器類型)
  • 元件 (站台伺服器、伺服器定位器點、發佈點、管理點、報告點、資料庫伺服器、提供者、傳送者、用戶端存取點)
  • 站台碼 (SMS 站台碼)
  • 伺服器類型 (中央、主要、次要站台伺服器)
  • 名稱 (NetBIOS 名稱)
  • 資料庫伺服器類型 (站台資料庫伺服器)

您可以選取 [Microsoft.SystemCenter.ConfigurationManager.2007.ServersGroup] 群組或報告之物件選擇器中的 [Microsoft.SystemCenter.ConfigurationManager.2007.SMS_Server_Class] 物件來執行此報告。

效能報告

效能報告通常是根據 Configuration Manager 伺服器角色或物件 (例如，管理點或資料探索記錄) 來分組。這些群組會再細分為原始 (總計) 與速度 (每秒或每分) 類型，這樣報告中的值可以使用適當的單位表示。

報告與其效能計數器會以此方式組織，方便您進行趨勢分析與疑難排解。調查 Configuration Manager 基礎結構中的問題時通常會使用物件報告，進行疑難排解 (例如，疑難排解管理點的問題) 時則通常會使用伺服器角色報告。

Configuration Manager 2007 伺服器效能群組報告

若要執行下列報告，請選取物件選擇器目標群組中的 [Microsoft.SystemCenter.ConfigurationManager.2007.ServerPerformanceGroup]。

ConfigMgr 2007 資料探索記錄速度效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的資料探索記錄 (DDR) 處理速度。

ConfigMgr 2007 效能測量:站台伺服器 DDR 處理速度 | 每分鐘處理的 DDR 數
ConfigMgr 2007 效能測量:MP DDR Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:DMP DDR 處理速度 | 每秒產生的探索報告數

ConfigMgr 2007 資料探索記錄原始效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的 DDR 待處理項目與處理的總數。

ConfigMgr 2007 效能測量:站台伺服器 DDR 待處理項目 | 已加入佇列的資料探索記錄顯示總數
ConfigMgr 2007 效能測量:已處理的站台伺服器 DDR 總數 | 每秒報告總數
ConfigMgr 2007 效能測量:DMP DDR 處理速度 | 每秒產生的探索報告數

ConfigMgr 2007 裝置管理點原始效能

此報告會顯示 Configuration Manager 2007 裝置管理點伺服器角色處理的總數。

ConfigMgr 2007 效能測量:已處理的 DMP DDR 總數 | 已產生的探索報告總數
ConfigMgr 2007 效能測量:已處理的 DMP HINV 總數 | 已產生的硬體清查報告總數
ConfigMgr 2007 效能測量:已處理的 DMP SINV 總數 | 已產生的軟體清查報告總數
ConfigMgr 2007 效能測量:已處理的 DMP 狀態訊息總數 | 已產生的狀態訊息總數
ConfigMgr 2007 效能測量:已發送的 DMP ISAPI 要求總數 | 已發送的訊息總數
ConfigMgr 2007 效能測量:已接收的 DMP ISAPI 要求總數 | 已接收的訊息總數

ConfigMgr 2007 裝置管理點速度效能

此報告會顯示 Configuration Manager 2007 裝置管理點伺服器角色的處理速度。

ConfigMgr 2007 效能測量:DMP 設定要求速度 | 每秒的 DMP 設定要求數
ConfigMgr 2007 效能測量:DMP 電腦設定要求速度 | 每秒的電腦設定要求數
ConfigMgr 2007 效能測量:DMP 軟體原則識別碼要求速度 | 每秒的軟體原則識別碼要求數
ConfigMgr 2007 效能測量:DMP 軟體原則本文要求速度 | 每秒的軟體原則內容要求數
ConfigMgr 2007 效能測量:DMP 封裝版本要求速度 | 每秒的封裝版本要求數
ConfigMgr 2007 效能測量:DMP 探索轉譯要求速度 | 每秒的探索轉譯要求數
ConfigMgr 2007 效能測量:DMP 硬體清查轉譯要求速度 | 每秒的硬體清查轉譯要求數
ConfigMgr 2007 效能測量:DMP 資料庫連線嘗試速度 | 每秒的資料庫連線嘗試數
ConfigMgr 2007 效能測量:DMP DDR 處理速度 | 每秒產生的探索報告數
ConfigMgr 2007 效能測量:DMP HINV 處理速度 | 每秒產生的硬體清查報告數
ConfigMgr 2007 效能測量:DMP DP 位置要求處理速度 | 每秒產生的位置要求數
ConfigMgr 2007 效能測量:DMP ISAPI 訊息處理速度 | 每秒分派的訊息數
ConfigMgr 2007 效能測量:DMP SINV 處理速度 | 每秒產生的軟體清查報告數
ConfigMgr 2007 效能測量:DMP 狀態處理速度 | 每秒產生的狀態訊息數

ConfigMgr 2007 硬體清查速度效能

此報告會顯示所有適用之 SMS 伺服器角色的硬體清查 (HINV) 處理速度。

ConfigMgr 2007 效能測量:站台伺服器 HINV 處理速度 | 每分鐘處理的 MIF 數
ConfigMgr 2007 效能測量:MP HINV Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:MP HINV Retry Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:DMP HINV 處理速度 | 每秒產生的硬體清查報告數

ConfigMgr 2007 硬體清查原始效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的 HINV 待處理項目與處理的總數。

ConfigMgr 2007 效能測量:站台伺服器 HINV 待處理項目 | 已加入佇列的 MIF 總數
ConfigMgr 2007 效能測量:已處理的站台伺服器 HINV 總數 | 已處理的 MIF 總數
ConfigMgr 2007 效能測量:MP HINV 待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP HINV Mgr (報告總數) | 報告總數
ConfigMgr 2007 效能測量:已處理的 DMP HINV 總數 | 已產生的硬體清查報告總數

ConfigMgr 2007 管理點速度效能

此報告會顯示 Configuration Manager 2007 管理點伺服器角色的處理速度。

ConfigMgr 2007 效能測量:MP Location Mgr (每秒的 MP 要求數) | 每秒的 MP 要求數
ConfigMgr 2007 效能測量:MP Location Mgr (每秒的 DP 要求數) | 每秒的 DP 要求數
ConfigMgr 2007 效能測量:MP Get Policy (每秒的要求數) | 每秒的要求數
ConfigMgr 2007 效能測量:MP Get Auth (每秒的要求數) | 每秒的要求數
ConfigMgr 2007 效能測量:MP Policy Mgr (每秒的 PA 要求數) | 每秒的 PA 要求數
ConfigMgr 2007 效能測量:MP DAL (每秒執行的 SP 數) | 每秒執行的 SP 數
ConfigMgr 2007 效能測量:MP HINV Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:MP HINV Retry Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:MP SINV Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:MP SINV ColFile Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:MP Relay Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:MP Status Mgr (每秒事件總數) | 每秒事件總數

ConfigMgr 2007 管理點原始效能

此報告會顯示 Configuration Manager 2007 管理點伺服器角色的待處理項目和處理的總數。

ConfigMgr 2007 效能測量:MP DDR 待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP DDR Mgr (報告總數) | 報告總數
ConfigMgr 2007 效能測量:MP HINV 待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP HINV Mgr (報告總數) | 報告總數
ConfigMgr 2007 效能測量:MP 檔案收集待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP SINV 待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP SINV Mgr (報告總數) | 報告總數
ConfigMgr 2007 效能測量:MP Relay Mgr 待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP Relay Mgr (報告總數) | 報告總數
ConfigMgr 2007 效能測量:MP 狀態待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP Status Mgr (事件總數) | 事件總數

ConfigMgr 2007 伺服器效能資源效能

此報告會顯示 Configuration Manager 2007 伺服器角色的系統資源使用狀況。

ConfigMgr 2007 效能測量:記憶體 - 確認使用中的位元組百分比 | 已認可的使用位元數
ConfigMgr 2007 效能測量:分頁檔案 - 使用百分比 | 使用百分比
ConfigMgr 2007 效能測量:處理器 - 處理器時間百分比 (總計) | 處理器時間百分比
ConfigMgr 2007 效能測量:處理程序 - 處理器時間百分比 (smsexec) | 處理器時間百分比
ConfigMgr 2007 效能測量:處理程序 - 處理器時間百分比 (ccmexec) | 處理器時間百分比
ConfigMgr 2007 效能測量:系統 - 系統執行時間 | 系統執行時間

ConfigMgr 2007 站台伺服器原始效能

此報告會顯示 Configuration Manager 2007 站台伺服器角色的處理速度。

ConfigMgr 2007 效能測量:站台伺服器排程器工作待處理項目 | 工作數
ConfigMgr 2007 效能測量:站台伺服器排程器傳送要求待處理項目 | 傳送要求數
ConfigMgr 2007 效能測量:SMS Executive 執行緒狀態執行中執行緒總數 | 執行中執行緒數
ConfigMgr 2007 效能測量:站台伺服器 DDR 待處理項目 | 已加入佇列的 DDR 總數
ConfigMgr 2007 效能測量:已處理的站台伺服器 DDR 總數 | 已處理的 DDR 總數
ConfigMgr 2007 效能測量:站台伺服器 HINV 待處理項目 | 已加入佇列的 MIF 總數
ConfigMgr 2007 效能測量:已處理的站台伺服器 HINV 總數 | 已處理的 MIF 總數
ConfigMgr 2007 效能測量:站台伺服器 SINV 待處理項目 | 已加入佇列的 SINV 總數
ConfigMgr 2007 效能測量:已處理的站台伺服器 SINV 總數 | 已處理的 SINV 總數
ConfigMgr 2007 效能測量:站台伺服器 SWM 待處理項目 | 已加入佇列的 SWM 使用檔案總數
ConfigMgr 2007 效能測量:已處理的站台伺服器 SWM 總數 | 已處理的 SWM 使用檔案總數
ConfigMgr 2007 效能測量:已處理的站台伺服器狀態訊息總數 | 已接收
ConfigMgr 2007 效能測量:已處理的 SMS 狀況系統訊息記錄總數 | 已處理的訊息記錄總數
ConfigMgr 2007 效能測量:已處理的 SMS 狀況系統無效訊息記錄總數 | 已處理的無效訊息記錄總數
ConfigMgr 2007 效能測量:已放棄的 SMS 狀況系統訊息記錄總數 | 已放棄的訊息記錄總數
ConfigMgr 2007 效能測量:已處理的 SMS 狀況系統訊息檔案總數 | 已處理的訊息檔案總數
ConfigMgr 2007 效能測量:已處理的 SMS 狀況系統損壞訊息檔案總數 | 已處理的損壞訊息檔案總數
ConfigMgr 2007 效能測量:SMS 狀況系統訊息檔案處理執行緒數 | 訊息檔案處理執行緒數
ConfigMgr 2007 效能測量:SMS 線上醒機通訊管理員已傳送的封包總數 | 已傳送的封包總數
ConfigMgr 2007 效能測量:SMS 線上醒機通訊管理員失敗的封包總數 | 失敗的封包總數
ConfigMgr 2007 效能測量:SMS 線上醒機通訊管理員擱置中的要求總數 | 擱置中的要求總數

ConfigMgr 2007 站台伺服器速度效能

此報告會顯示 Configuration Manager 2007 站台伺服器角色的處理速度。

ConfigMgr 2007 效能測量:站台伺服器 HINV 處理速度 | 每分鐘處理的 MIF 數
ConfigMgr 2007 效能測量:站台伺服器 SINV 處理速度 | 每分鐘處理的 SINV 數
ConfigMgr 2007 效能測量:站台伺服器 SWM 處理速度 | 每分鐘處理的 SWM 使用記錄數
ConfigMgr 2007 效能測量:站台伺服器狀態處理速度 | 每秒的處理數
ConfigMgr 2007 效能測量:SMS 狀況系統訊息記錄處理速度 | 處理速度
ConfigMgr 2007 效能測量:SMS 狀況系統訊息檔案處理速度 | 每分鐘處理的訊息檔案數
ConfigMgr 2007 效能測量:SMS 線上醒機通訊管理員每秒的封包數 | 每秒的封包數

ConfigMgr 2007 軟體清查速度效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的軟體清查 (SINV) 處理速度。

ConfigMgr 2007 效能測量:站台伺服器 SINV 處理速度 | 每分鐘處理的 SINV 數
ConfigMgr 2007 效能測量:MP Sinv Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:MP Sinv ColFile Mgr (每秒報告總數) | 每秒報告總數
ConfigMgr 2007 效能測量:DMP SINV 處理速度 | 每秒產生的軟體清查報告數

ConfigMgr 2007 軟體清查原始效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的 SINV 待處理項目與處理的總數。

ConfigMgr 2007 效能測量:站台伺服器 SINV 待處理項目 | 已加入佇列的 SINV 總數
ConfigMgr 2007 效能測量:已處理的站台伺服器 SINV 總數 | 已處理的 SINV 總數
ConfigMgr 2007 效能測量:MP FileCollection 待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP SINV 待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP Sinv Mgr (報告總數) | 報告總數
ConfigMgr 2007 效能測量:已處理的 DMP SINV 總數 | 已產生的軟體清查報告總數

ConfigMgr 2007 軟體計量原始效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的軟體計量 (SWM) 待處理項目與處理的總數。

ConfigMgr 2007 效能測量:站台伺服器 SWM 待處理項目 | 已加入佇列的 SWM 使用檔案總數
ConfigMgr 2007 效能測量:已處理的站台伺服器 SWM 總數 | 已處理的 SWM 使用記錄總數
ConfigMgr 2007 效能測量:MP Relay Mgr 待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP Relay Mgr (報告總數) | 報告總數

ConfigMgr 2007 軟體計量速度效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的 SWM 處理速度。

ConfigMgr 2007 效能測量:站台伺服器 SWM 處理速度 | 每分鐘處理的 SWM 使用記錄數
ConfigMgr 2007 效能測量:MP Relay Mgr (每秒報告總數) | 每秒報告總數

ConfigMgr 2007 狀況訊息原始效能

此報告會顯示所有適用之 SMS 伺服器角色的 Configuration Manager 2007 狀況訊息待處理項目與處理的總數。

ConfigMgr 2007 效能測量:已處理的 SMS 狀況系統訊息記錄總數 | 已處理的訊息記錄總數
ConfigMgr 2007 效能測量:已處理的 SMS 狀況系統無效訊息記錄總數 | 已處理的無效訊息記錄總數
ConfigMgr 2007 效能測量:已放棄的 SMS 狀況系統訊息記錄總數 | 已放棄的訊息記錄總數
ConfigMgr 2007 效能測量:已處理的 SMS 狀況系統訊息檔案總數 | 已處理的訊息檔案總數
ConfigMgr 2007 效能測量:已處理的 SMS 狀況系統損壞訊息記錄總數 | 已處理的損壞訊息檔案總數
ConfigMgr 2007 效能測量:SMS 狀況系統訊息檔案處理執行緒數 | 訊息檔案處理執行緒數
ConfigMgr 2007 效能測量:已處理的 MP 狀況訊息數 | 訊息總數
ConfigMgr 2007 效能測量:拒絕的 MP 狀況訊息數 | 拒絕的訊息數

ConfigMgr 2007 狀況訊息速度效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的 SMS 狀況訊息處理速度。

ConfigMgr 2007 效能測量:SMS 狀況系統訊息記錄處理速度 | 每分鐘處理的訊息記錄數
ConfigMgr 2007 效能測量:SMS 狀況系統訊息檔案處理速度 | 每分鐘處理的訊息檔案數
ConfigMgr 2007 效能測量:MP 狀況訊息處理速度 | 每秒的訊息數

ConfigMgr 2007 狀態訊息原始效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的 SMS 狀態訊息待處理項目與處理的總數。

ConfigMgr 2007 效能測量:已處理的站台伺服器狀態訊息總數 | 已接收
ConfigMgr 2007 效能測量:MP 狀態待處理項目 | 已佇列的訊息數
ConfigMgr 2007 效能測量:MP Status Mgr (事件總數) | 事件總數
ConfigMgr 2007 效能測量:已處理的 DMP 狀態訊息總數 | 已產生的狀態訊息總數

ConfigMgr 2007 狀態訊息速度效能

此報告會顯示所有適用之 Configuration Manager 2007 伺服器角色的 SMS 狀態訊息處理速度。

ConfigMgr 2007 效能測量:站台伺服器狀態處理速度 | 每秒的處理數
ConfigMgr 2007 效能測量:MP Status Mgr (每秒事件總數) | 每秒事件總數
ConfigMgr 2007 效能測量:DMP 狀態處理速度 | 每秒產生的狀態訊息數

ConfigMgr 2007 支援伺服器角色效能

此報告會顯示支援 Configuration Manager 2007 伺服器角色的服務效能。

ConfigMgr 2007 效能測量:Web 服務 (每秒的 ISAPI 擴充程式要求數)

每秒的 ISAPI 擴充程式要求數

請參閱

概念

Configuration Manager 2007 管理組件的其他資源
Configuration Manager 2007 管理組件的站台與元件
Configuration Manager 2007 管理組件的電腦群組
Configuration Manager 2007 管理組件的安裝類別
Configuration Manager 2007 管理組件的指令碼
Configuration Manager 2007 管理組件的檢視
Configuration Manager 2007 管理組件的圖表